media-gfx/imagemagick: add missing test restrict
authorThomas Deutschmann <whissi@gentoo.org>
Sun, 10 Nov 2019 21:23:49 +0000 (22:23 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Sun, 10 Nov 2019 21:25:25 +0000 (22:25 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
media-gfx/imagemagick/imagemagick-6.9.10.71.ebuild
media-gfx/imagemagick/imagemagick-7.0.9.2.ebuild
media-gfx/imagemagick/imagemagick-9999.ebuild

index 070e4668a698b92744054d5f38ae5649513aa7c3..104ec59adc776bb7afad37d6b402d7fcbe48b4b6 100644 (file)
@@ -16,7 +16,12 @@ LICENSE="imagemagick"
 SLOT="0/${PV}"
 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
 IUSE="bzip2 corefonts cxx djvu fftw fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl openexr openmp pango perl png postscript q32 q8 raw static-libs svg test tiff truetype webp wmf X xml zlib"
-RESTRICT="!test? ( test ) perl? ( userpriv )"
+
+REQUIRED_USE="corefonts? ( truetype )
+       test? ( corefonts )"
+
+RESTRICT="perl? ( userpriv )
+       !test? ( test )"
 
 RDEPEND="
        dev-libs/libltdl:0
@@ -62,9 +67,6 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig
        X? ( x11-base/xorg-proto )"
 
-REQUIRED_USE="corefonts? ( truetype )
-       test? ( corefonts )"
-
 S="${WORKDIR}/${MY_P}"
 
 src_prepare() {
index bbac5a8baac3ee53dcc483169b7107a421d2eee1..8d8ee8a769b2c74f4410b8115a71250d8c0d0b96 100644 (file)
@@ -24,6 +24,11 @@ SLOT="0/7.0.9"
 IUSE="bzip2 corefonts cxx djvu fftw fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl openexr openmp pango perl png postscript q32 q8 raw static-libs svg test tiff truetype webp wmf X xml zlib"
 RESTRICT="!test? ( test )"
 
+REQUIRED_USE="corefonts? ( truetype )
+       test? ( corefonts )"
+
+RESTRICT="!test? ( test )"
+
 BDEPEND="virtual/pkgconfig"
 
 RDEPEND="
@@ -70,9 +75,6 @@ DEPEND="${RDEPEND}
        !media-gfx/graphicsmagick[imagemagick]
        X? ( x11-base/xorg-proto )"
 
-REQUIRED_USE="corefonts? ( truetype )
-       test? ( corefonts )"
-
 S="${WORKDIR}/${MY_P}"
 
 src_prepare() {
index bbac5a8baac3ee53dcc483169b7107a421d2eee1..8d8ee8a769b2c74f4410b8115a71250d8c0d0b96 100644 (file)
@@ -24,6 +24,11 @@ SLOT="0/7.0.9"
 IUSE="bzip2 corefonts cxx djvu fftw fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl openexr openmp pango perl png postscript q32 q8 raw static-libs svg test tiff truetype webp wmf X xml zlib"
 RESTRICT="!test? ( test )"
 
+REQUIRED_USE="corefonts? ( truetype )
+       test? ( corefonts )"
+
+RESTRICT="!test? ( test )"
+
 BDEPEND="virtual/pkgconfig"
 
 RDEPEND="
@@ -70,9 +75,6 @@ DEPEND="${RDEPEND}
        !media-gfx/graphicsmagick[imagemagick]
        X? ( x11-base/xorg-proto )"
 
-REQUIRED_USE="corefonts? ( truetype )
-       test? ( corefonts )"
-
 S="${WORKDIR}/${MY_P}"
 
 src_prepare() {