app-editors/qhexedit2: bump snapshot
authorRick Farina <zerochaos@gentoo.org>
Tue, 17 Mar 2020 01:51:53 +0000 (21:51 -0400)
committerRick Farina <zerochaos@gentoo.org>
Tue, 17 Mar 2020 01:52:00 +0000 (21:52 -0400)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
app-editors/qhexedit2/Manifest
app-editors/qhexedit2/qhexedit2-0.8.6_p20190316.ebuild [new file with mode: 0644]

index 89e26c7dbc8e604fd9e88fc82f97cb0ed136c7c1..79e9033f9ab739ccec2389e6fdee4609f00ba394 100644 (file)
@@ -1,2 +1,3 @@
 DIST qhexedit2-0.8.4.tar.gz 340766 BLAKE2B af24031fdd9f8d677f7e8ab8fd69667852dd971db30f5406b9aaaa08bf7f2dc692c87e99c141f355adc82c8226b5b29f53ce07ba63656d866f8688cb2cbc67f2 SHA512 8ed831d75c8ec1897dfd7ef497423908b26b0f56e6577928ed035654e52b437f64edd61cfcc1de6eaf5d1f29f9dc97da84d2edd7f427e3c09c9d75d7bc6504ff
 DIST qhexedit2-0.8.4_p20170719.tar.gz 342037 BLAKE2B 667a7c3e93ed3422f21da53b6811fca53b210cfaf2603cf2a61e377e68f295b5024a9fa73d444c1e50af274bdbc6faa62bc2ab4aad176a8b3a6d7540117c5a30 SHA512 3c412b9bbe4f84f6f445b6ad530fc51dc5422a0a5bb6184edc7df92595aa5215c345e2b16effae8de758b299c5f7f7d44cf54dd65a180941c30790194679baa8
+DIST qhexedit2-0.8.6_p20190316.tar.gz 355512 BLAKE2B a7edc8d05a7788f3a3f2202762ca3dc436cafbde1b1216ff1bb342055600a2e9d53c27fe324380331b8182904545c698106129238065cd2416d244fdfa176446 SHA512 4ef288c8a220c308d38c41fee83fe962e213cdfa448445ef73c3d2fe1952b68f2096732e78d2aa0a87eddd3cf2f47bed3e77807e12d2b7616c1447b3bf1b0e7d
diff --git a/app-editors/qhexedit2/qhexedit2-0.8.6_p20190316.ebuild b/app-editors/qhexedit2/qhexedit2-0.8.6_p20190316.ebuild
new file mode 100644 (file)
index 0000000..2378ef1
--- /dev/null
@@ -0,0 +1,85 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_OPTIONAL=1
+
+inherit distutils-r1 qmake-utils
+
+EGIT_COMMIT="ba5af8616b3a6c916e718914225a483267c01356"
+DESCRIPTION="Hex editor library, Qt application written in C++ with Python bindings"
+HOMEPAGE="https://github.com/lancos/qhexedit2/"
+SRC_URI="https://github.com/lancos/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +gui python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-0.8.4-setup.py.patch"
+)
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtgui:5
+       dev-qt/qtwidgets:5
+       python? (
+               dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+               dev-python/sip[${PYTHON_USEDEP}]
+               ${PYTHON_DEPS}
+               )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+src_prepare() {
+       default
+       sed -i -e '/^unix:DESTDIR/ d' -e "\$atarget.path = /usr/$(get_libdir)" \
+               -e "\$aINSTALLS += target" src/qhexedit.pro \
+               || die "src/qhexedit.pro: sed failed"
+       use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+       eqmake5 src/qhexedit.pro
+       if use gui; then
+               cd example || die "can't cd example"
+               eqmake5 qhexedit.pro
+       fi
+}
+
+src_compile() {
+       default
+       use python && distutils-r1_src_compile
+       use gui && emake -C example
+}
+
+python_compile() {
+       use python && distutils-r1_python_compile build_ext --library-dirs="${S}"
+}
+
+src_test() {
+       cd test || die "can't cd test"
+       mkdir logs || die "can't create logs dir"
+       eqmake5 chunks.pro
+       emake
+       ./chunks || die "test run failed"
+       grep -q "^NOK" logs/Summary.log && die "test failed"
+}
+
+src_install() {
+       emake INSTALL_ROOT="${D}" install
+       doheader src/*.h
+       use python && distutils-r1_src_install
+       use gui && dobin example/qhexedit
+       if use doc; then
+               dodoc -r doc/html
+               dodoc doc/release.txt
+       fi
+}