media-libs/libnspsl: bump to version 0.1.5
authorPhilipp Ammann <philipp.ammann@posteo.de>
Sun, 27 Oct 2019 08:45:42 +0000 (08:45 +0000)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 4 Dec 2019 14:48:33 +0000 (16:48 +0200)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Philipp Ammann <philipp.ammann@posteo.de>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-libs/libnspsl/Manifest
media-libs/libnspsl/libnspsl-0.1.5.ebuild [new file with mode: 0644]

index 1328789808ee0bfde2873285ce5ae74290475bd6..bd50f96ec746c579ff8786c2f40e6263e53466e7 100644 (file)
@@ -1 +1,2 @@
 DIST libnspsl-0.1.3-src.tar.gz 311065 BLAKE2B ef846482c677e98a9eae646597e893f4e94161a60482127a88440a3786d2f9e3c4458a823ac878c64bc7d1b00080653facc28f408d2a44b571835958966297af SHA512 da4069dee152d126d53e442c8ced1438707db1ccee779bd2abe752a8d1dc30e40036037674e220bb24adad49fe406633e0d07e5d29d209b9fb223107c0e89415
+DIST libnspsl-0.1.5-src.tar.gz 316104 BLAKE2B e20d2ef94758943b848b6785bf462d5bab706c8396b10e22d3fa6d3718a78ee26aa1bb361e084dc28fcec3cc7498ed5774eea5fc086ca620c3c135e101a71300 SHA512 a46cc8eda6f22936e8d2477b16c094b1e7f9668071823aaf07d2a3c6cc0af645ea4d4cb3ae9fdafcc8dd77602bed736a8ae82f588ba7d56f5c774736da7e1baa
diff --git a/media-libs/libnspsl/libnspsl-0.1.5.ebuild b/media-libs/libnspsl/libnspsl-0.1.5.ebuild
new file mode 100644 (file)
index 0000000..c7c011b
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="decoding library for BMP and ICO image file formats, written in C"
+HOMEPAGE="http://www.netsurf-browser.org/projects/"
+SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~m68k-mint"
+IUSE=""
+
+BDEPEND="
+       dev-util/netsurf-buildsystem
+       virtual/pkgconfig"
+
+_emake() {
+       source /usr/share/netsurf-buildsystem/gentoo-helpers.sh
+       netsurf_define_makeconf
+       emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
+}
+
+src_compile() {
+       _emake
+}
+
+src_install() {
+       _emake DESTDIR="${ED}" install
+}