Version bump
authorRenat Lumpau <rl03@gentoo.org>
Wed, 3 Jan 2007 19:03:17 +0000 (19:03 +0000)
committerRenat Lumpau <rl03@gentoo.org>
Wed, 3 Jan 2007 19:03:17 +0000 (19:03 +0000)
Package-Manager: portage-2.1.2_rc4-r4

www-apps/phprojekt/ChangeLog
www-apps/phprojekt/files/digest-phprojekt-5.2 [new file with mode: 0644]
www-apps/phprojekt/phprojekt-4.2.3.ebuild
www-apps/phprojekt/phprojekt-5.2.ebuild [new file with mode: 0644]

index e3e99762624535f1522f418c39deff59f89ec849..63ea8ed4a69923902c30ed08735511b5e48ead04 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for www-apps/phprojekt
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phprojekt/ChangeLog,v 1.22 2006/11/23 17:24:26 vivo Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phprojekt/ChangeLog,v 1.23 2007/01/03 19:03:17 rl03 Exp $
+
+*phprojekt-5.2 (03 Jan 2007)
+
+  03 Jan 2007; Renat Lumpau <rl03@gentoo.org> phprojekt-4.2.3.ebuild,
+  -phprojekt-5.1.2.ebuild, +phprojekt-5.2.ebuild:
+  Version bump
 
   23 Nov 2006; Francesco Riosa <vivo@gentoo.org> phprojekt-4.2.3.ebuild,
   phprojekt-5.1.2.ebuild:
diff --git a/www-apps/phprojekt/files/digest-phprojekt-5.2 b/www-apps/phprojekt/files/digest-phprojekt-5.2
new file mode 100644 (file)
index 0000000..172f6f1
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 1f117c82a8687c74445e8d58200d9aeb phprojekt-5.2.tar.gz 1710877
+RMD160 df7ddf9bf3ab852ab088fd8d9dacae3cc3e65b07 phprojekt-5.2.tar.gz 1710877
+SHA256 8069dd81cae3557d480778cae84d2fc28b98833cdecd435a11e971389b819bae phprojekt-5.2.tar.gz 1710877
index cb1e1bb323357ba80071d8348796e444c49ef694..5950b517719f7a0beb4c196a9d734e2a5fd608da 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/phprojekt/phprojekt-4.2.3.ebuild,v 1.4 2006/11/23 17:24:26 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phprojekt/phprojekt-4.2.3.ebuild,v 1.5 2007/01/03 19:03:17 rl03 Exp $
 
 inherit webapp eutils
 
@@ -12,11 +12,9 @@ SRC_URI="mirror://gentoo/${P}.tar.gz
 
 LICENSE="GPL-2"
 KEYWORDS="ppc x86"
-IUSE="postgres mysql"
+IUSE=""
 
 RDEPEND="net-www/apache
-               postgres? ( dev-db/postgresql )
-               mysql? ( virtual/mysql )
                virtual/php"
 DEPEND="app-arch/unzip"
 
diff --git a/www-apps/phprojekt/phprojekt-5.2.ebuild b/www-apps/phprojekt/phprojekt-5.2.ebuild
new file mode 100644 (file)
index 0000000..91a5b84
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/phprojekt/phprojekt-5.2.ebuild,v 1.1 2007/01/03 19:03:17 rl03 Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Project management and coordination system"
+HOMEPAGE="http://www.phprojekt.com/"
+#SRC_URI="http://phprojekt.com/releases/${PN}/${P}.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86"
+IUSE="postgres mysql"
+
+#DEPEND="app-arch/unzip"
+
+need_php
+
+pkg_setup () {
+       webapp_pkg_setup
+       local php_flags="imap"
+       use mysql && php_flags="${php_flags} mysql"
+       use postgres && php_flags="${php_flags} postgres"
+       require_php_with_use ${php_flags}
+}
+
+src_install() {
+       webapp_src_preinst
+       dodoc readme install
+       local file
+
+       cp -R . ${D}/${MY_HTDOCSDIR}
+       for file in attach chat; do
+               webapp_serverowned ${MY_HTDOCSDIR}/${file}
+       done
+       webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+       webapp_src_install
+}