sys-process/daemontools-encore: bump to v1.11
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 18 Jan 2019 02:50:10 +0000 (03:50 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 18 Jan 2019 02:51:00 +0000 (03:51 +0100)
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-process/daemontools-encore/Manifest
sys-process/daemontools-encore/daemontools-encore-1.11.ebuild [new file with mode: 0644]
sys-process/daemontools-encore/files/daemontools-encore-1.11-add-missing-setuser-man-page.patch [new file with mode: 0644]
sys-process/daemontools-encore/files/daemontools-encore-1.11-do-not-always-run-tests.patch [new file with mode: 0644]

index 843461195af8d9ee835a81ee447a4bb04b80a38b..bddd090077fb26cc1a24c366285f4e1800e4cb7a 100644 (file)
@@ -1 +1,2 @@
 DIST daemontools-encore-1.10.tar.gz 87096 BLAKE2B f0e5accc319caa1b4f4f15f5bdf2c2d59c5f398698509ad288a9b7ba33944fb49155386bf0edebda20959ea1c7d1fce14be883a0a96c1d2e054886c7df17d64a SHA512 569030fb9941186f167644740d0424987105b7a818d5a3cdb4e90ced5530a16938b7205141ca2f198f83362269f9cc28eb5acafe9cd7f985c8e56d307f706767
+DIST daemontools-encore-1.11.tar.gz 94917 BLAKE2B 747da62ae97d4e4b28ca5309cbf835fe989db23d9f7a408bcce6fa7b17a658740024867daf9116dcbcb02e16a6b0ee92210bd485ecceef9b7ecbb2e0ea79e110 SHA512 1e1a96a948d551bfc38496740eaa85b7cae0d2469419293b133533da75ca03657fe6108129703ad7b773925c58ce84a4f242eb612133fb0c499f47ae50423a8a
diff --git a/sys-process/daemontools-encore/daemontools-encore-1.11.ebuild b/sys-process/daemontools-encore/daemontools-encore-1.11.ebuild
new file mode 100644 (file)
index 0000000..80d87fa
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic qmail
+
+DESCRIPTION="Collection of tools for managing UNIX services"
+HOMEPAGE="https://untroubled.org/daemontools-encore/"
+SRC_URI="https://untroubled.org/daemontools-encore/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="selinux static"
+
+DEPEND=""
+RDEPEND="selinux? ( sec-policy/selinux-daemontools )
+       !sys-process/daemontools
+       !app-doc/daemontools-man"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.11-do-not-always-run-tests.patch
+       "${FILESDIR}"/${PN}-1.11-add-missing-setuser-man-page.patch
+)
+
+src_compile() {
+       use static && append-ldflags -static
+       qmail_set_cc
+       emake
+}
+
+src_install() {
+       keepdir /service
+
+       echo "${ED%/}/usr/bin" >conf-bin
+       echo "${ED%/}/usr/share/man" >conf-man
+       dodir /usr/bin
+       dodir /usr/share/man
+       emake install
+
+       dodoc ChangeLog CHANGES CHANGES.djb README TODO
+
+       newinitd "${FILESDIR}"/svscan.init-2 svscan
+}
+
+pkg_postinst() {
+       einfo
+       einfo "You can run daemontools using the svscan init.d script,"
+       einfo "or you could run it through inittab."
+       einfo "To use inittab, emerge supervise-scripts and run:"
+       einfo "svscan-add-to-inittab"
+       einfo "Then you can hup init with the command telinit q"
+       einfo
+}
diff --git a/sys-process/daemontools-encore/files/daemontools-encore-1.11-add-missing-setuser-man-page.patch b/sys-process/daemontools-encore/files/daemontools-encore-1.11-add-missing-setuser-man-page.patch
new file mode 100644 (file)
index 0000000..58b159b
--- /dev/null
@@ -0,0 +1,68 @@
+Add missing setuser.8
+
+Upstream-bug: https://github.com/bruceg/daemontools-encore/issues/60
+
+--- /dev/null
++++ b/setuser.8
+@@ -0,0 +1,61 @@
++.TH setuser 8
++.SH NAME
++setuser \- runs another program under a specified account's environment.
++.SH SYNOPSIS
++.B setuser
++.I account
++.I child
++.SH DESCRIPTION
++.I account
++is a single argument.
++.I child
++consists of one or more arguments. 
++
++.B setuser
++sets
++.BR $GID ,
++.BR $UID ,
++.BR $SHELL ,
++.BR $HOME ,
++and
++.BR $USER
++to
++.IR account 's
++gid number, uid number, login shell, home directory, and user name, respectively.
++It changes the working directory to
++.IR account 's
++home, and sets its uid and gid to
++.IR account 's
++uid and gid, with supplementary groups set up.
++It then runs
++.IR child .
++
++.B setuser
++cannot be run by anyone other than root.
++.SH EXIT CODES
++.B setuser
++exits 111 if it cannot find a UNIX account named
++.IB account ,
++if it cannot setup the environment, change directory, setgid, setuid, or run
++.IR child .
++Otherwise its exit code is the same as that of
++.IR child .
++.SH SEE ALSO
++envdir(8),
++envini(8),
++envuidgid(8),
++fghack(8),  
++multilog(8),
++pgrphack(8),
++readproctitle(8),
++setlock(8),
++setuidgid(8),
++softlimit(8),
++supervise(8),
++svc(8),
++svok(8),
++svscan(8),
++svscanboot(8),
++svstat(8),
++tai64n(8),
++tai64nlocal(8)
diff --git a/sys-process/daemontools-encore/files/daemontools-encore-1.11-do-not-always-run-tests.patch b/sys-process/daemontools-encore/files/daemontools-encore-1.11-do-not-always-run-tests.patch
new file mode 100644 (file)
index 0000000..e23faad
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -66,6 +66,9 @@ byte_rchr.o: \
+ compile byte_rchr.c hasmemrchr.h byte.h
+       ./compile byte_rchr.c
++check: \
++rts
++
+ chkshsgr: \
+ load chkshsgr.o
+       ./load chkshsgr 
+@@ -247,7 +250,7 @@ compile iopause.c taia.h tai.h uint64.h select.h iopause.h
+       ./compile iopause.c
+ it: \
+-rts sysdeps man
++programs sysdeps man
+ load: \
+ conf-ld print-ld.sh systype warn-auto.sh