always run automake if the configure file calls AM_INIT_AUTOMAKE #397697 by My Th
authorMike Frysinger <vapier@gentoo.org>
Wed, 4 Jan 2012 22:00:27 +0000 (22:00 +0000)
committerMike Frysinger <vapier@gentoo.org>
Wed, 4 Jan 2012 22:00:27 +0000 (22:00 +0000)
eclass/autotools.eclass

index daaa4b09044f0a20ba7dd4eb96507eddd177e597..79791e0de27583163f8851d90661eb90b6cfbee9 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2011 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.116 2011/12/14 20:46:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.117 2012/01/04 22:00:27 vapier Exp $
 
 # @ECLASS: autotools.eclass
 # @MAINTAINER:
@@ -256,14 +256,12 @@ eautomake() {
 
        # Run automake if:
        #  - a Makefile.am type file exists
-       #  - a Makefile.in type file exists and the configure
-       #    script is using the AM_INIT_AUTOMAKE directive
-       for makefile_name in {GNUmakefile,{M,m}akefile}.{am,in} "" ; do
+       #  - the configure script is using the AM_INIT_AUTOMAKE directive
+       for makefile_name in {GNUmakefile,{M,m}akefile}.am "" ; do
                [[ -f ${makefile_name} ]] && break
        done
-       [[ -z ${makefile_name} ]] && return 0
 
-       if [[ ${makefile_name} == *.in ]] ; then
+       if [[ -z ${makefile_name} ]] ; then
                if ! grep -qs AM_INIT_AUTOMAKE configure.?? ; then
                        return 0
                fi