dev-perl/DBD-mysql: Fix compiling against MariaDB 10.2 bug #634192
authorKent Fredric <kentnl@gentoo.org>
Thu, 19 Oct 2017 23:53:16 +0000 (12:53 +1300)
committerKent Fredric <kentnl@gentoo.org>
Thu, 19 Oct 2017 23:53:59 +0000 (12:53 +1300)
rbump needed because compiles can break and install without errors
if you disabled tests.

Bug: https://bugs.gentoo.org/634192
Package-Manager: Portage-2.3.8, Repoman-2.3.3

dev-perl/DBD-mysql/DBD-mysql-4.41.0-r2.ebuild [moved from dev-perl/DBD-mysql/DBD-mysql-4.41.0-r1.ebuild with 97% similarity]
dev-perl/DBD-mysql/files/4.041-mariadb-10.2.patch [new file with mode: 0644]

similarity index 97%
rename from dev-perl/DBD-mysql/DBD-mysql-4.41.0-r1.ebuild
rename to dev-perl/DBD-mysql/DBD-mysql-4.41.0-r2.ebuild
index dd0e5c3e5dc234fc25ff12d8646da6a9d7a48964..34f18b06e628bfac543ac8c6fc50331f24eee943 100644 (file)
@@ -33,6 +33,7 @@ DEPEND="${RDEPEND}
 PATCHES=(
        "${FILESDIR}/${DIST_VERSION}-no-dot-inc.patch"
        "${FILESDIR}/${DIST_VERSION}-amvis-type-conversions.patch"
+       "${FILESDIR}/${DIST_VERSION}-mariadb-10.2.patch"
 )
 src_configure() {
        if use test; then
diff --git a/dev-perl/DBD-mysql/files/4.041-mariadb-10.2.patch b/dev-perl/DBD-mysql/files/4.041-mariadb-10.2.patch
new file mode 100644 (file)
index 0000000..13fa277
--- /dev/null
@@ -0,0 +1,35 @@
+From 509fd6a054de9408ce9032e93fff61f6bdbc568a Mon Sep 17 00:00:00 2001
+From: Brian Evans <grknight@gentoo.org>
+Date: Fri, 13 Oct 2017 15:03:50 -0400
+Subject: Fix building/linking against MariaDB 10.2
+
+Bug: https://bugs.gentoo.org/634192
+---
+ mysql.xs | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/mysql.xs b/mysql.xs
+index 13c6a57..6de3c8e 100644
+--- a/mysql.xs
++++ b/mysql.xs
+@@ -790,7 +790,7 @@ dbd_mysql_get_info(dbh, sql_info_type)
+     D_imp_dbh(dbh);
+     IV type = 0;
+     SV* retsv=NULL;
+-#if !defined(MARIADB_BASE_VERSION) && MYSQL_VERSION_ID >= 50709
++#if ( !defined(MARIADB_BASE_VERSION) && MYSQL_VERSION_ID >= 50709 ) || MYSQL_VERSION_ID >= 100202
+ /* MariaDB 10 is not MySQL source level compatible so this only applies to MySQL*/
+     IV buffer_len;
+ #endif 
+@@ -822,7 +822,7 @@ dbd_mysql_get_info(dbh, sql_info_type)
+           retsv = newSVpvn("`", 1);
+           break;
+       case SQL_MAXIMUM_STATEMENT_LENGTH:
+-#if !defined(MARIADB_BASE_VERSION) && MYSQL_VERSION_ID >= 50709
++#if ( !defined(MARIADB_BASE_VERSION) && MYSQL_VERSION_ID >= 50709 ) || MYSQL_VERSION_ID >= 100202
+         /* MariaDB 10 is not MySQL source level compatible so this
+            only applies to MySQL*/
+           /* mysql_get_option() was added in mysql 5.7.3 */
+-- 
+2.14.2
+