dev-qt/qtbluetooth: fix build with with clang++ and libc++
authorDenis Pronin <dannftk@yandex.ru>
Mon, 17 Feb 2020 16:05:04 +0000 (19:05 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 16 Mar 2020 21:25:46 +0000 (22:25 +0100)
Signed-off-by: Denis Pronin <dannftk@yandex.ru>
Closes: https://github.com/gentoo/gentoo/pull/14686
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-qt/qtbluetooth/files/qtbluetooth-5.14.1-errno.patch [new file with mode: 0644]
dev-qt/qtbluetooth/qtbluetooth-5.14.1.ebuild

diff --git a/dev-qt/qtbluetooth/files/qtbluetooth-5.14.1-errno.patch b/dev-qt/qtbluetooth/files/qtbluetooth-5.14.1-errno.patch
new file mode 100644 (file)
index 0000000..7f1ae71
--- /dev/null
@@ -0,0 +1,25 @@
+From 58e0224a6677667b1102b34ad5b35a787bd74077 Mon Sep 17 00:00:00 2001
+From: Denis Pronin <dannftk@yandex.ru>
+Date: Wed, 4 Mar 2020 00:59:07 +0300
+Subject: [PATCH] support building with clang and libc++
+
+fixed undefined errno when compiling with clang++ and libc++
+
+Change-Id: I30be6e2da36f9189261535f103ce689462634f49
+Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
+---
+ src/bluetooth/bluez/bluetoothmanagement.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/bluetooth/bluez/bluetoothmanagement.cpp b/src/bluetooth/bluez/bluetoothmanagement.cpp
+index 31d3dc02..b6ad93e5 100644
+--- a/src/bluetooth/bluez/bluetoothmanagement.cpp
++++ b/src/bluetooth/bluez/bluetoothmanagement.cpp
+@@ -51,6 +51,7 @@
+ #include <sys/types.h>
+ #include <linux/capability.h>
++#include <cerrno>
+ QT_BEGIN_NAMESPACE
index 7ded615ebf54dd5a49d2d67370aca45f7bcbaa96..6d4771dedd5ac32e6ee3e5ae893c774d585ec810 100644 (file)
@@ -24,6 +24,8 @@ DEPEND="${RDEPEND}
        ~dev-qt/qtnetwork-${PV}
 "
 
+PATCHES=( "${FILESDIR}/${P}-errno.patch" )
+
 src_prepare() {
        sed -i -e 's/nfc//' src/src.pro || die