dev-db/postgis: Drop 2.4.7, 2.4.8 and 2.5.2
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 13 Feb 2020 22:40:25 +0000 (23:40 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 13 Feb 2020 23:19:27 +0000 (00:19 +0100)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-db/postgis/Manifest
dev-db/postgis/postgis-2.4.7.ebuild [deleted file]
dev-db/postgis/postgis-2.4.8.ebuild [deleted file]
dev-db/postgis/postgis-2.5.2.ebuild [deleted file]

index 584507e4d9875a27a3331ae2d87f6c5547500f41..617516bdd3e04648a80cb90eedb0efe3c04ae4e9 100644 (file)
@@ -1,5 +1,2 @@
-DIST postgis-2.4.7.tar.gz 12831401 BLAKE2B 0069a339cc778a02a008835189b5560ffb1724aceaaeeec5264750cdfaa4346310ca1d112f698556e750b6559f0dabb727584c9d41ff8747ed7673e147c9723e SHA512 832f039e582227cd1c6edef98af8dfcceb90db75b18d4ba605b7baf2842227b23fe2d15c3b1cde941182c93230ba41ab94da59e97506c77e79f2016bbd98c885
-DIST postgis-2.4.8.tar.gz 12846228 BLAKE2B dc7cd26f08774011bddba362040f35fd46dab5f58870643d4e6d939fb107a8e93ccb8c2d57ac67bf5ba44a7dd05c25eee77358548d9d7d9a8b3e2f7538e49538 SHA512 afeddbdcbad68358c3bc36beec5f1baf74c328daba90f0ac7d6322e4330d18da2e5534fa200f8ae3f19e7e897221989a564f6e2855e9181eadfd9cc32315b666
-DIST postgis-2.5.2.tar.gz 16252761 BLAKE2B 181ecc41e659c1df32392d0dfea9cc081c2a647fd23401b8b0470f99e1136b6b8ed900eaea38afdf87cc801bf13ede4247f9c188fcf0da6782624239c77b434f SHA512 b10781f0b74bad8162c33eb111a6090fba184b45fe5874d22cd3a5b0acfb057f3407c073bc44c9d4cd20ed8c2cb1fbb34480b0cf331340bc8b52580d4eccb819
 DIST postgis-2.5.3.tar.gz 16424752 BLAKE2B 94c2ccd41eb88a39c6db48ad7f4d142742a1b0791e3abe57adb2c778406dcc8286afc6d55c80067e0b94a1300eff1c76a227d3cfd813e12541c715edeea11a9b SHA512 1c9f873ba8f8ff4aeae248c68c001eb4174416de1e00ce6a0d0c9ea129b475e887a83235027068d52f587ab95c549adbfaa7e5dccdda77855e39c55dac0fdc2d
 DIST postgis-3.0.0.tar.gz 17359802 BLAKE2B aa83bdc2d1950c517f99cbdd877eb7261f6c29ce2cbd9f67f1e606c290080fc3d02ab0b7ceb68ce852e0c0d3d4b7753f03cb5b0921da164ab65d68e23d1df538 SHA512 82c233681fa6444686f9979768e5d6d3a9b6ca9cbd4fc2b14bd0a5d1269a8d0f45ee067e64984077063407c7abc13fa0e37a29928d7ccbfe3a61b694f592bed2
diff --git a/dev-db/postgis/postgis-2.4.7.ebuild b/dev-db/postgis/postgis-2.4.7.ebuild
deleted file mode 100644 (file)
index 2b057bb..0000000
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-POSTGRES_COMPAT=( 9.{4..6} {10..11} )
-POSTGRES_USEDEP="server"
-
-inherit autotools eutils postgres-multi versionator
-
-MY_PV=$(replace_version_separator 3 '')
-MY_P="${PN}-${MY_PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Geographic Objects for PostgreSQL"
-HOMEPAGE="http://postgis.net"
-SRC_URI="http://download.osgeo.org/postgis/source/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="address-standardizer doc gtk static-libs mapbox test topology"
-
-RDEPEND="
-       ${POSTGRES_DEP}
-       dev-libs/json-c:=
-       dev-libs/libxml2:2
-       >=sci-libs/geos-3.5.0
-       >=sci-libs/proj-4.6.0
-       >=sci-libs/gdal-1.10.0
-       address-standardizer? ( dev-libs/libpcre )
-       gtk? ( x11-libs/gtk+:2 )
-       mapbox? ( dev-libs/protobuf )
-"
-
-DEPEND="${RDEPEND}
-               doc? (
-                               app-text/docbook-xsl-stylesheets
-                               app-text/docbook-xml-dtd:4.5
-                               dev-libs/libxslt
-                               || (
-                                       media-gfx/imagemagick[png]
-                                       media-gfx/graphicsmagick[imagemagick,png]
-                               )
-               )
-               virtual/pkgconfig
-               test? ( dev-util/cunit )
-"
-
-PGIS="$(get_version_component_range 1-2)"
-
-REQUIRED_USE="test? ( doc ) ${POSTGRES_REQ_USE}"
-
-# Needs a running psql instance, doesn't work out of the box
-RESTRICT="test"
-
-MAKEOPTS+=' -j1'
-
-# These modules are built using the same *FLAGS that were used to build
-# dev-db/postgresql. The right thing to do is to ignore the current
-# *FLAGS settings.
-QA_FLAGS_IGNORED="usr/lib(64)?/(rt)?postgis-${PGIS}\.so"
-
-src_prepare() {
-       eapply "${FILESDIR}/${PN}-2.2.0-arflags.patch"
-
-       local AT_M4DIR="macros"
-       eautoreconf
-
-       postgres-multi_src_prepare
-}
-
-src_configure() {
-       local myargs=""
-
-       use gtk                  && myargs+=" --with-gui"
-
-       use address-standardizer || myargs+=" --without-address-standardizer"
-       use mapbox               || myargs+=" --without-protobuf"
-       use topology             || myargs+=" --without-topology"
-
-       postgres-multi_foreach econf ${myargs}
-}
-
-src_compile() {
-       postgres-multi_foreach emake
-       postgres-multi_foreach emake -C topology
-
-       if use doc ; then
-               postgres-multi_foreach emake comments
-               postgres-multi_foreach emake cheatsheets
-               postgres-multi_forbest emake -C doc html
-       fi
-}
-
-src_install() {
-       postgres-multi_foreach emake DESTDIR="${D}" install
-       postgres-multi_foreach emake -C topology DESTDIR="${D}" install
-       postgres-multi_forbest dobin ./utils/postgis_restore.pl
-
-       dodoc CREDITS TODO loader/README.* doc/*txt
-
-       docinto topology
-       dodoc topology/{TODO,README}
-
-       if use doc ; then
-               postgres-multi_foreach emake DESTDIR="${D}" comments-install
-
-               docinto html
-               postgres-multi_forbest dodoc doc/html/{postgis.html,style.css}
-
-               docinto html/images
-               postgres-multi_forbest dodoc doc/html/images/*
-       fi
-
-       use static-libs || find "${ED}" -name '*.a' -delete
-}
-
-pkg_postinst() {
-       ebegin "Refreshing PostgreSQL symlinks"
-       postgresql-config update
-       eend $?
-
-       elog "To finish installing PostGIS, follow the directions detailed at:"
-       elog "http://postgis.net/docs/manual-${PGIS}/postgis_installation.html#create_new_db_extensions"
-}
diff --git a/dev-db/postgis/postgis-2.4.8.ebuild b/dev-db/postgis/postgis-2.4.8.ebuild
deleted file mode 100644 (file)
index 7248b26..0000000
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-POSTGRES_COMPAT=( 9.{4..6} {10..11} )
-POSTGRES_USEDEP="server"
-
-inherit autotools eutils postgres-multi versionator
-
-MY_PV=$(replace_version_separator 3 '')
-MY_P="${PN}-${MY_PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Geographic Objects for PostgreSQL"
-HOMEPAGE="http://postgis.net"
-SRC_URI="http://download.osgeo.org/postgis/source/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="address-standardizer doc gtk static-libs mapbox test topology"
-
-RDEPEND="
-       ${POSTGRES_DEP}
-       dev-libs/json-c:=
-       dev-libs/libxml2:2
-       >=sci-libs/geos-3.5.0
-       >=sci-libs/proj-4.6.0
-       >=sci-libs/gdal-1.10.0
-       address-standardizer? ( dev-libs/libpcre )
-       gtk? ( x11-libs/gtk+:2 )
-       mapbox? ( dev-libs/protobuf )
-"
-
-DEPEND="${RDEPEND}
-               doc? (
-                               app-text/docbook-xsl-stylesheets
-                               app-text/docbook-xml-dtd:4.5
-                               dev-libs/libxslt
-                               || (
-                                       media-gfx/imagemagick[png]
-                                       media-gfx/graphicsmagick[imagemagick,png]
-                               )
-               )
-               virtual/pkgconfig
-               test? ( dev-util/cunit )
-"
-
-PGIS="$(get_version_component_range 1-2)"
-
-REQUIRED_USE="test? ( doc ) ${POSTGRES_REQ_USE}"
-
-# Needs a running psql instance, doesn't work out of the box
-RESTRICT="test"
-
-MAKEOPTS+=' -j1'
-
-# These modules are built using the same *FLAGS that were used to build
-# dev-db/postgresql. The right thing to do is to ignore the current
-# *FLAGS settings.
-QA_FLAGS_IGNORED="usr/lib(64)?/(rt)?postgis-${PGIS}\.so"
-
-src_prepare() {
-       eapply "${FILESDIR}/${PN}-2.2.0-arflags.patch"
-
-       local AT_M4DIR="macros"
-       eautoreconf
-
-       postgres-multi_src_prepare
-}
-
-src_configure() {
-       local myargs=""
-
-       use gtk                  && myargs+=" --with-gui"
-
-       use address-standardizer || myargs+=" --without-address-standardizer"
-       use mapbox               || myargs+=" --without-protobuf"
-       use topology             || myargs+=" --without-topology"
-
-       postgres-multi_foreach econf ${myargs}
-}
-
-src_compile() {
-       postgres-multi_foreach emake
-       postgres-multi_foreach emake -C topology
-
-       if use doc ; then
-               postgres-multi_foreach emake comments
-               postgres-multi_foreach emake cheatsheets
-               postgres-multi_forbest emake -C doc html
-       fi
-}
-
-src_install() {
-       postgres-multi_foreach emake DESTDIR="${D}" install
-       postgres-multi_foreach emake -C topology DESTDIR="${D}" install
-       postgres-multi_forbest dobin ./utils/postgis_restore.pl
-
-       dodoc CREDITS TODO loader/README.* doc/*txt
-
-       docinto topology
-       dodoc topology/{TODO,README}
-
-       if use doc ; then
-               postgres-multi_foreach emake DESTDIR="${D}" comments-install
-
-               docinto html
-               postgres-multi_forbest dodoc doc/html/{postgis.html,style.css}
-
-               docinto html/images
-               postgres-multi_forbest dodoc doc/html/images/*
-       fi
-
-       use static-libs || find "${ED}" -name '*.a' -delete
-}
-
-pkg_postinst() {
-       ebegin "Refreshing PostgreSQL symlinks"
-       postgresql-config update
-       eend $?
-
-       elog "To finish installing PostGIS, follow the directions detailed at:"
-       elog "http://postgis.net/docs/manual-${PGIS}/postgis_installation.html#create_new_db_extensions"
-}
diff --git a/dev-db/postgis/postgis-2.5.2.ebuild b/dev-db/postgis/postgis-2.5.2.ebuild
deleted file mode 100644 (file)
index 39283ce..0000000
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-POSTGRES_COMPAT=( 9.{4..6} {10..12} )
-POSTGRES_USEDEP="server"
-
-inherit autotools eutils postgres-multi versionator
-
-MY_PV=$(replace_version_separator 3 '')
-MY_P="${PN}-${MY_PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Geographic Objects for PostgreSQL"
-HOMEPAGE="http://postgis.net"
-SRC_URI="http://download.osgeo.org/postgis/source/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="address-standardizer doc gtk static-libs mapbox test topology"
-
-RDEPEND="
-       ${POSTGRES_DEP}
-       dev-libs/json-c:=
-       dev-libs/libxml2:2
-       >=sci-libs/geos-3.5.0
-       >=sci-libs/proj-4.6.0
-       >=sci-libs/gdal-1.10.0
-       address-standardizer? ( dev-libs/libpcre )
-       gtk? ( x11-libs/gtk+:2 )
-       mapbox? ( dev-libs/protobuf )
-"
-
-DEPEND="${RDEPEND}
-               doc? (
-                               app-text/docbook-xsl-stylesheets
-                               app-text/docbook-xml-dtd:4.5
-                               dev-libs/libxslt
-                               || (
-                                       media-gfx/imagemagick[png]
-                                       media-gfx/graphicsmagick[imagemagick,png]
-                               )
-               )
-               virtual/pkgconfig
-               test? ( dev-util/cunit )
-"
-
-PGIS="$(get_version_component_range 1-2)"
-
-REQUIRED_USE="test? ( doc ) ${POSTGRES_REQ_USE}"
-
-# Needs a running psql instance, doesn't work out of the box
-RESTRICT="test"
-
-# These modules are built using the same *FLAGS that were used to build
-# dev-db/postgresql. The right thing to do is to ignore the current
-# *FLAGS settings.
-QA_FLAGS_IGNORED="usr/lib(64)?/(rt)?postgis-${PGIS}\.so"
-
-src_prepare() {
-       eapply "${FILESDIR}/${PN}-2.2.0-arflags.patch"
-
-       local AT_M4DIR="macros"
-       eautoreconf
-
-       postgres-multi_src_prepare
-}
-
-src_configure() {
-       local myargs=""
-
-       use gtk                  && myargs+=" --with-gui"
-
-       use address-standardizer || myargs+=" --without-address-standardizer"
-       use mapbox               || myargs+=" --without-protobuf"
-       use topology             || myargs+=" --without-topology"
-
-       postgres-multi_foreach econf ${myargs}
-}
-
-src_compile() {
-       postgres-multi_foreach emake
-       postgres-multi_foreach emake -C topology
-
-       if use doc ; then
-               postgres-multi_foreach emake comments
-               postgres-multi_foreach emake cheatsheets
-               postgres-multi_forbest emake -C doc html
-       fi
-}
-
-src_install() {
-       postgres-multi_foreach emake DESTDIR="${D}" install
-       postgres-multi_foreach emake -C topology DESTDIR="${D}" install
-       postgres-multi_forbest dobin ./utils/postgis_restore.pl
-
-       dodoc CREDITS TODO loader/README.* doc/*txt
-
-       docinto topology
-       dodoc topology/{TODO,README}
-
-       if use doc ; then
-               postgres-multi_foreach emake DESTDIR="${D}" comments-install
-
-               docinto html
-               postgres-multi_forbest dodoc doc/html/{postgis.html,style.css}
-
-               docinto html/images
-               postgres-multi_forbest dodoc doc/html/images/*
-       fi
-
-       use static-libs || find "${ED}" -name '*.a' -delete
-}
-
-pkg_postinst() {
-       ebegin "Refreshing PostgreSQL symlinks"
-       postgresql-config update
-       eend $?
-
-       elog "To finish installing PostGIS, follow the directions detailed at:"
-       elog "http://postgis.net/docs/manual-${PGIS}/postgis_installation.html#create_new_db_extensions"
-}