dev-ml/menhir: fix build with ocamlbuild 0.9.1
authorAlexis Ballier <aballier@gentoo.org>
Tue, 1 Mar 2016 18:44:00 +0000 (19:44 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 1 Mar 2016 18:47:37 +0000 (19:47 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/menhir/files/ocamlbuild.patch [new file with mode: 0644]
dev-ml/menhir/menhir-20151112.ebuild

diff --git a/dev-ml/menhir/files/ocamlbuild.patch b/dev-ml/menhir/files/ocamlbuild.patch
new file mode 100644 (file)
index 0000000..6a8743f
--- /dev/null
@@ -0,0 +1,13 @@
+Index: menhir-20151112/src/Makefile
+===================================================================
+--- menhir-20151112.orig/src/Makefile
++++ menhir-20151112/src/Makefile
+@@ -19,7 +19,7 @@ endif
+ # ----------------------------------------------------------------------------
+ # Ocamlbuild tool and settings.
+-OCAMLBUILD := ocamlbuild -classic-display -j 0 -cflags "-safe-string -bin-annot"
++OCAMLBUILD := ocamlbuild -no-hygiene -classic-display -j 0 -cflags "-safe-string -bin-annot"
+ # ----------------------------------------------------------------------------
+ # For everyday development.
index 61fb1e2d35a7c65d22a94b2ceaa59d4e17cd15c8..1b7e19d30348e2f731e8fad1c6c0e1a0b4dddaa1 100644 (file)
@@ -4,7 +4,7 @@
 
 EAPI=5
 
-inherit findlib
+inherit findlib eutils
 
 DESCRIPTION="LR(1) parser generator for the OCaml language"
 HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
@@ -19,6 +19,10 @@ RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]"
 DEPEND="${RDEPEND}
        dev-ml/ocamlbuild"
 
+src_prepare() {
+       epatch "${FILESDIR}/ocamlbuild.patch"
+}
+
 src_configure() {
        if ! use ocamlopt ; then
                export TARGET=byte