app-admin/mongo-tools: bump to 3.6.5
authorTomas Mozes <hydrapolic@gmail.com>
Fri, 25 May 2018 12:30:10 +0000 (14:30 +0200)
committerUltrabug <ultrabug@gentoo.org>
Mon, 11 Jun 2018 19:25:13 +0000 (21:25 +0200)
Package-Manager: Portage-2.3.38, Repoman-2.3.9

app-admin/mongo-tools/Manifest
app-admin/mongo-tools/mongo-tools-3.6.5.ebuild [new file with mode: 0644]

index 88627c6b6ce49f8971b0c2e8c55a3956a6f74f17..6ab03912068efcda7e589937746755e9ee4d4f74 100644 (file)
@@ -8,3 +8,4 @@ DIST mongo-tools-3.4.15.tar.gz 4697188 BLAKE2B 690ec3187cb781c9cae903a27eca9d1d5
 DIST mongo-tools-3.6.2.tar.gz 4693924 BLAKE2B 61c44d579f6eb4013ee6c0118ebe89a2d454ef8cf6ad933479885cb71d169185272b03d9c63fa738d67bbd1b9efd4bc964eb17adcc5002508589d198cdb17752 SHA512 5ac2b1d2b33271f63c406c69bd8a576a21f4dcaa6f75839e0f907ebc9968f0e121eb3800e88da050c120856e7ddda4f12d551bb731d4acac0f5cf09f66fc948a
 DIST mongo-tools-3.6.3.tar.gz 4693833 BLAKE2B fc7139984cf3dcb7b4ce6f6c2028296651aa59ac68d7068bdf748e28eeb65b1fd9b07580d0c93f3f41dbb01030a12433a07a04deadf28e0ff792387fa78ae4aa SHA512 7dba782c84a728aa9ceb28cbd9934f58b615dccfb238a9dbd63b18661ba4e74ddba21f93d9f12e6d80d293ebe42a82d31fa64448aacdba75bd07d964a5f631fc
 DIST mongo-tools-3.6.4.tar.gz 4693872 BLAKE2B 5d72b32fa8ad7bc106c6ea3c09a27a093b9a1ae2392b4fa534042c5461fdc2b958dcbbf32e0ed596be234921e2ee21cc8f6132d57ae870a234abfc7adbb3b2e9 SHA512 53d06fa4a1b58de8001d6bf6e85f7edc97ce2cfbbb69c1ab05219deaa05ad9dd77d93f98c5526b4f58644a766e1b0f123686358095f059c71a4277634603f23f
+DIST mongo-tools-3.6.5.tar.gz 4720814 BLAKE2B 5dd064f70557ec1ab979d08523f3dd305fb310c533b69bc99be3ad3d006036354f62b9f3d61c242e1481a254bed538a5e1cf5662f0e35705f1c50a76f31fddbb SHA512 dd2d7cc64043b42a70b5de0ea493f94722a4476248bfd77d6892861e4be6ab20175992367965dfd687bf8b7ebece6113b7f7a3e59256497e3ecd7e2678875965
diff --git a/app-admin/mongo-tools/mongo-tools-3.6.5.ebuild b/app-admin/mongo-tools/mongo-tools-3.6.5.ebuild
new file mode 100644 (file)
index 0000000..3589981
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl ssl"
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+       dev-lang/go:=
+       net-libs/libpcap
+       sasl? ( dev-libs/cyrus-sasl )
+       ssl? ( dev-libs/openssl:0= )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       default
+
+       # do not substitute version because it uses git
+       sed -i '/^sed/,+3d' build.sh || die
+       sed -i '/^stty/d' build.sh || die
+       sed -i '/^mv/d' build.sh || die
+
+       # build pie to avoid text relocations wrt #582854
+       # skip on ppc64 wrt #610984
+       if ! use ppc64; then
+               sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
+       fi
+
+       # ensure we use bash wrt #582906
+       sed -i 's@/bin/sh@/bin/bash@g' build.sh || die
+}
+
+src_compile() {
+       local myconf=()
+
+       if use sasl; then
+         myconf+=(sasl)
+       fi
+
+       if use ssl; then
+         myconf+=(ssl)
+       fi
+
+       ./build.sh ${myconf[@]} || die "build failed"
+}
+
+src_install() {
+       dobin bin/*
+}