net-misc/dhcpcd: Removed old.
authorLars Wendler <polynomial-c@gentoo.org>
Sun, 28 Jul 2019 12:04:15 +0000 (14:04 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sun, 28 Jul 2019 12:04:15 +0000 (14:04 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-misc/dhcpcd/Manifest
net-misc/dhcpcd/dhcpcd-8.0.0.ebuild [deleted file]

index 9cb3689630b3ebe5fa9b0a1c7c15878990aa1d4a..a48d7f266da2dc997f815501ab42baaf8c631ec9 100644 (file)
@@ -1,4 +1,3 @@
 DIST dhcpcd-7.1.1.tar.xz 211788 BLAKE2B 984ec97ffdcb15883f57f9e2a699a7c8f006b2630e7651ab9d55e7a980045f8891f09d9f7be420969203a59671d097a1ed76621fe4a62ff26a5020fc8becfe69 SHA512 8791e718d65ef8ae23a16b98e82824860fa91914e6eb0a42cdbbca28236c1c38005ada44214bde33aac57152fe675debebdb5d141b67dcfc82012996d8337bb4
 DIST dhcpcd-7.2.3.tar.xz 213552 BLAKE2B 5f89e11424b85702b05da6207ec346480c029de1416cc8892471de428ca0a4395a8915700e2237bfa2b133648973bc2a7c7d15aa2d0ba492f96fbf3908d7f613 SHA512 271cca422fad10eaf842acfd5b590c0ad537f5f23ee919a3928d8ad98463ab03bde21c0bc08741ea9618ee31095160a7c00066155eae2c74b17c49af65ba566f
-DIST dhcpcd-8.0.0.tar.xz 221624 BLAKE2B 1173a930a4fd0a262cfabfa9e0964cc11a9bd56da5eed6a8d75c47bcfcde982be038f21b28f4f07ba3b558d9a220ca798e43e5703e504aa7bbd9f928678268a1 SHA512 97994587a6478e781dd5b246f9521e62d955ffb6b753367e5d6f8f05a6cfb9a6da684b4ee7b9d97a9a792db8ee0aba99644ead4c7a4ae8043c40eb6ddf36dd2d
 DIST dhcpcd-8.0.1.tar.xz 221716 BLAKE2B 597831ed9a965170d0dc9ffdaa8ab34e209b14fa6183ed7a0b915f545d654db32d0994eb9e6f12953f5b81220abfc186ac72da1cd3e60f8b0cdee21da4be56dd SHA512 2931345fb50b63a49ee97b290dbb236895dd13a19ce17bf40b50797cf93ea959272de698718593f882ba0c35e2f733b5476135759f46bd04a8e8f11e81ba9f3f
diff --git a/net-misc/dhcpcd/dhcpcd-8.0.0.ebuild b/net-misc/dhcpcd/dhcpcd-8.0.0.ebuild
deleted file mode 100644 (file)
index 491c778..0000000
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd toolchain-funcs
-
-if [[ ${PV} == "9999" ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="https://roy.marples.name/git/dhcpcd.git"
-else
-       MY_P="${P/_alpha/-alpha}"
-       MY_P="${MY_P/_beta/-beta}"
-       MY_P="${MY_P/_rc/-rc}"
-       SRC_URI="https://roy.marples.name/downloads/${PN}/${MY_P}.tar.xz"
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-       S="${WORKDIR}/${MY_P}"
-fi
-
-DESCRIPTION="A fully featured, yet light weight RFC2131 compliant DHCP client"
-HOMEPAGE="https://roy.marples.name/projects/dhcpcd"
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="elibc_glibc +embedded ipv6 kernel_linux +udev"
-
-COMMON_DEPEND="udev? ( virtual/udev )"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-
-src_configure() {
-       local myeconfargs=(
-               --dbdir="${EPREFIX}/var/lib/dhcpcd"
-               --libexecdir="${EPREFIX}/lib/dhcpcd"
-               --localstatedir="${EPREFIX}/var"
-               --prefix="${EPREFIX}"
-               --with-hook=ntp.conf
-               $(use_enable embedded)
-               $(use_enable ipv6)
-               $(usex elibc_glibc '--with-hook=yp.conf' '')
-               $(usex kernel_linux '--rundir=${EPREFIX}/run' '')
-               $(usex udev '' '--without-dev --without-udev')
-               CC="$(tc-getCC)"
-       )
-       econf "${myeconfargs[@]}"
-}
-
-src_install() {
-       default
-       keepdir /var/lib/dhcpcd
-       newinitd "${FILESDIR}"/${PN}.initd ${PN}
-       systemd_dounit "${FILESDIR}"/${PN}.service
-}
-
-pkg_postinst() {
-       local dbdir="${EROOT}"/var/lib/dhcpcd old_files=()
-
-       local old_old_duid="${EROOT}"/var/lib/dhcpcd/dhcpcd.duid
-       local old_duid="${EROOT}"/etc/dhcpcd.duid
-       local new_duid="${dbdir}"/duid
-       if [[ -e "${old_old_duid}" ]] ; then
-               # Upgrade the duid file to the new format if needed
-               if ! grep -q '..:..:..:..:..:..' "${old_old_duid}"; then
-                       sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_old_duid}"
-               fi
-
-               # Move the duid to /etc, a more sensible location
-               if [[ ! -e "${old_duid}" ]] ; then
-                       cp -p "${old_old_duid}" "${new_duid}"
-               fi
-               old_files+=( "${old_old_duid}" )
-       fi
-
-       # dhcpcd-7 moves the files out of /etc
-       if [[ -e "${old_duid}" ]] ; then
-               if [[ ! -e "${new_duid}" ]] ; then
-                       cp -p "${old_duid}" "${new_duid}"
-               fi
-               old_files+=( "${old_duid}" )
-       fi
-       local old_secret="${EROOT}"/etc/dhcpcd.secret
-       local new_secret="${dbdir}"/secret
-       if [[ -e "${old_secret}" ]] ; then
-               if [[ ! -e "${new_secret}" ]] ; then
-                       cp -p "${old_secret}" "${new_secret}"
-               fi
-               old_files+=( "${old_secret}" )
-       fi
-
-       # dhcpcd-7 renames some files in /var/lib/dhcpcd
-       local old_rdm="${dbdir}"/dhcpcd-rdm.monotonic
-       local new_rdm="${dbdir}"/rdm_monotonic
-       if [[ -e "${old_rdm}" ]] ; then
-               if [[ ! -e "${new_rdm}" ]] ; then
-                       cp -p "${old_rdm}" "${new_rdm}"
-               fi
-               old_files+=( "${old_rdm}" )
-       fi
-       local lease=
-       for lease in "${dbdir}"/dhcpcd-*.lease*; do
-               [[ -f "${lease}" ]] || continue
-               old_files+=( "${lease}" )
-               local new_lease=$(basename "${lease}" | sed -e "s/dhcpcd-//")
-               [[ -e "${dbdir}/${new_lease}" ]] && continue
-               cp "${lease}" "${dbdir}/${new_lease}"
-       done
-
-       # Warn about removing stale files
-       if [[ -n "${old_files[@]}" ]] ; then
-               elog
-               elog "dhcpcd-7 has copied dhcpcd.duid and dhcpcd.secret from"
-               elog "${EROOT}/etc to ${dbdir}"
-               elog "and copied leases in ${dbdir} to new files with the dhcpcd-"
-               elog "prefix dropped."
-               elog
-               elog "You should remove these files if you don't plan on reverting"
-               elog "to an older version:"
-               local old_file=
-               for old_file in ${old_files[@]}; do
-                       elog "  ${old_file}"
-               done
-       fi
-
-       if [ -z "${REPLACING_VERSIONS}" ]; then
-               elog
-               elog "dhcpcd has zeroconf support active by default."
-               elog "This means it will always obtain an IP address even if no"
-               elog "DHCP server can be contacted, which will break any existing"
-               elog "failover support you may have configured in your net configuration."
-               elog "This behaviour can be controlled with the noipv4ll configuration"
-               elog "file option or the -L command line switch."
-               elog "See the dhcpcd and dhcpcd.conf man pages for more details."
-
-               elog
-               elog "Dhcpcd has duid enabled by default, and this may cause issues"
-               elog "with some dhcp servers. For more information, see"
-               elog "https://bugs.gentoo.org/show_bug.cgi?id=477356"
-       fi
-
-       if ! has_version net-dns/bind-tools; then
-               elog
-               elog "If you activate the lookup-hostname hook to look up your hostname"
-               elog "using the dns, you need to install net-dns/bind-tools."
-       fi
-}