net-misc/youtube-dl: Old
authorJeroen Roovers <jer@gentoo.org>
Thu, 7 May 2020 12:34:12 +0000 (14:34 +0200)
committerJeroen Roovers <jer@gentoo.org>
Thu, 7 May 2020 12:47:51 +0000 (14:47 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-misc/youtube-dl/Manifest
net-misc/youtube-dl/youtube-dl-2020.03.24.ebuild [deleted file]

index 1cace85e063ede14bf1325b6706d0ad16c5a9adb..dcd7645cd9fb3bdb3967a4f4cc70d1013b5d67a5 100644 (file)
@@ -1,2 +1 @@
-DIST youtube-dl-2020.03.24.tar.gz 3165706 BLAKE2B 817cd8762f496255e58f909ab04f5fec3627918b4d9b58a9ab12c8bd56a12f672067c1dfe0808d76a96bc97fc7bc9a9e661c4f176577c0257f45d5cf6d0c7b92 SHA512 421c0ae412977cdf94d079aa7982360ffdfc4271bb7af27a598adbdb8454c2044e5c44ff3a9f339e9b0989c1264223ca83bba6a9151d01052f8f72c076d9e369
 DIST youtube-dl-2020.05.03.tar.gz 3169742 BLAKE2B af0d6192ef564111d42b452c95e4d275217c5230a6a19413aa08b152a5e5f37eb50abe3f14d7fe09cbca0c85ce9a79f0e92c7e1a9a2648c6c8668866d64ff7c3 SHA512 52cbbe49f17489cdf30298c300a7615f53d329305f3afac282fd5ecdb069641644064bf70a7ef93874252a7c206b2f1da42781e81542878261c21b7017950bc7
diff --git a/net-misc/youtube-dl/youtube-dl-2020.03.24.ebuild b/net-misc/youtube-dl/youtube-dl-2020.03.24.ebuild
deleted file mode 100644 (file)
index 9dc88df..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=(python3_{6,7,8})
-inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
-
-DESCRIPTION="Download videos from YouTube.com (and more sites...)"
-HOMEPAGE="https://github.com/ytdl-org/youtube-dl/"
-SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
-LICENSE="public-domain"
-
-KEYWORDS="amd64 arm ~arm64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="
-       dev-python/pycryptodome[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-"
-DEPEND="
-       ${RDEPEND}
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/flake8[${PYTHON_USEDEP}]
-       )
-"
-S=${WORKDIR}/${PN}
-
-src_compile() {
-       distutils-r1_src_compile
-}
-
-python_test() {
-       emake offlinetest
-}
-
-python_install_all() {
-       dodoc README.txt
-       doman ${PN}.1
-
-       newbashcomp ${PN}.bash-completion ${PN}
-
-       insinto /usr/share/zsh/site-functions
-       newins ${PN}.zsh _${PN}
-
-       insinto /usr/share/fish/vendor_completions.d
-       doins ${PN}.fish
-
-       distutils-r1_python_install_all
-
-       rm -r "${ED}"/usr/etc || die
-       rm -r "${ED}"/usr/share/doc/youtube_dl || die
-}
-
-pkg_postinst() {
-       elog "${PN}(1) / https://bugs.gentoo.org/355661 /"
-       elog "https://github.com/rg3/${PN}/blob/master/README.md#faq :"
-       elog
-       elog "${PN} works fine on its own on most sites. However, if you want"
-       elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
-       elog "On some sites - most notably YouTube - videos can be retrieved in"
-       elog "a higher quality format without sound. ${PN} will detect whether"
-       elog "ffmpeg is present and automatically pick the best option."
-       elog
-       elog "Videos or video formats streamed via RTMP protocol can only be"
-       elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
-       elog
-       elog "Downloading MMS and RTSP videos requires either mplayer"
-       elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
-       elog
-       elog "If you want ${PN} to embed thumbnails from the metadata into the"
-       elog "resulting MP4 files, consider installing media-video/atomicparsley"
-}