version bump
authorEray Aslan <eras@gentoo.org>
Wed, 4 Jan 2012 08:31:06 +0000 (08:31 +0000)
committerEray Aslan <eras@gentoo.org>
Wed, 4 Jan 2012 08:31:06 +0000 (08:31 +0000)
Package-Manager: portage-2.1.10.44/cvs/Linux x86_64

net-mail/cyrus-imap-admin/ChangeLog
net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.13.ebuild [new file with mode: 0644]
net-mail/cyrus-imapd/ChangeLog
net-mail/cyrus-imapd/cyrus-imapd-2.4.13.ebuild [new file with mode: 0644]

index ea262ca829f08b2310f7e41a194380101c40fbdd..cf131cc079c2460c757bce32001e0af4c861c1ee 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-mail/cyrus-imap-admin
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.108 2011/12/18 18:00:27 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/ChangeLog,v 1.109 2012/01/04 08:26:53 eras Exp $
+
+*cyrus-imap-admin-2.4.13 (04 Jan 2012)
+
+  04 Jan 2012; Eray Aslan <eras@gentoo.org> +cyrus-imap-admin-2.4.13.ebuild:
+  version bump
 
   18 Dec 2011; Raúl Porcel <armin76@gentoo.org>
   cyrus-imap-admin-2.4.12.ebuild:
diff --git a/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.13.ebuild b/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.13.ebuild
new file mode 100644 (file)
index 0000000..cc37d59
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imap-admin/cyrus-imap-admin-2.4.13.ebuild,v 1.1 2012/01/04 08:26:53 eras Exp $
+
+EAPI=4
+
+inherit eutils perl-app db-use
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Utilities and Perl modules to administer a Cyrus IMAP server."
+HOMEPAGE="http://www.cyrusimap.org/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-imapd/cyrus-imapd-${MY_PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="berkdb kerberos ssl"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+       >=dev-libs/cyrus-sasl-2.1.13
+       dev-perl/Term-ReadLine-Perl
+       dev-perl/TermReadKey
+       berkdb? ( >=sys-libs/db-3.2 )
+       ssl? ( >=dev-libs/openssl-0.9.6 )
+       kerberos? ( virtual/krb5 )"
+
+DEPEND="$RDEPEND"
+
+S="${WORKDIR}/cyrus-imapd-${MY_PV}"
+
+src_prepare() {
+       epatch "${FILESDIR}/${PN}-2.4.10-ldflags.patch"
+}
+
+src_configure() {
+       local myconf
+       if use berkdb ; then
+               myconf="--with-bdb-incdir=$(db_includedir)"
+       fi
+       econf \
+               --disable-server \
+               --enable-murder \
+               --enable-netscapehack \
+               --with-cyrus-group=mail \
+               --with-com_err=yes \
+               --with-perl=/usr/bin/perl \
+               --without-krb \
+               --without-krbdes \
+               $(use_with berkdb bdb) \
+               $(use_enable kerberos gssapi) \
+               $(use_with ssl openssl) \
+               ${myconf}
+}
+
+src_compile() {
+       emake -C "${S}/lib" all
+       emake -C "${S}/perl" all
+}
+
+src_install () {
+       emake -C "${S}/perl" DESTDIR="${D}" INSTALLDIRS=vendor install
+       fixlocalpod             # bug #98122
+}
index 09a50b210b9d0225ed40a2d4ade97cb87d7734b6..0a751838fec4b7442dcf6e0c734ad17d02db7d80 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for net-mail/cyrus-imapd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/ChangeLog,v 1.190 2011/10/24 14:12:40 eras Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/ChangeLog,v 1.191 2012/01/04 08:31:06 eras Exp $
+
+*cyrus-imapd-2.4.13 (04 Jan 2012)
+
+  04 Jan 2012; Eray Aslan <eras@gentoo.org> +cyrus-imapd-2.4.13.ebuild:
+  version bump
 
   24 Oct 2011; Eray Aslan <eras@gentoo.org> -cyrus-imapd-2.4.8.ebuild,
   -cyrus-imapd-2.4.9.ebuild, -cyrus-imapd-2.4.10.ebuild,
diff --git a/net-mail/cyrus-imapd/cyrus-imapd-2.4.13.ebuild b/net-mail/cyrus-imapd/cyrus-imapd-2.4.13.ebuild
new file mode 100644 (file)
index 0000000..1f9e341
--- /dev/null
@@ -0,0 +1,183 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/cyrus-imapd/cyrus-imapd-2.4.13.ebuild,v 1.1 2012/01/04 08:31:06 eras Exp $
+
+EAPI=4
+
+inherit db-use eutils ssl-cert pam multilib
+
+MY_P=${P/_/}
+
+DESCRIPTION="The Cyrus IMAP Server."
+HOMEPAGE="http://www.cyrusimap.org/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-imapd/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="afs berkdb kerberos mysql nntp pam postgres replication sieve snmp sqlite ssl tcpd"
+
+RDEPEND="sys-libs/zlib
+       >=dev-libs/cyrus-sasl-2.1.13
+       afs? ( net-fs/openafs )
+       berkdb? ( >=sys-libs/db-3.2 )
+       kerberos? ( virtual/krb5 )
+       mysql? ( virtual/mysql )
+       nntp? ( !net-nntp/leafnode )
+       pam? (
+                       virtual/pam
+                       >=net-mail/mailbase-1
+               )
+       postgres? ( dev-db/postgresql-base )
+       snmp? ( >=net-analyzer/net-snmp-5.2.2-r1 )
+       sqlite? ( dev-db/sqlite )
+       ssl? ( >=dev-libs/openssl-0.9.6 )
+       tcpd? ( >=sys-apps/tcp-wrappers-7.6 snmp? ( net-analyzer/net-snmp[tcpd=] ) )"
+
+DEPEND="$RDEPEND"
+
+# get rid of old style virtual - bug 350792
+# all blockers really needed?
+RDEPEND="${RDEPEND}
+       !mail-mta/courier
+       !net-mail/bincimap
+       !net-mail/courier-imap
+       !net-mail/uw-imap"
+
+REQUIRED_USE="afs? ( kerberos )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+       enewuser cyrus -1 -1 /usr/cyrus mail
+}
+
+src_prepare() {
+       # Fix master(8)->cyrusmaster(8) manpage.
+       for i in `grep -rl -e 'master\.8' -e 'master(8)' "${S}"` ; do
+               sed -i -e 's:master\.8:cyrusmaster.8:g' \
+                       -e 's:master(8):cyrusmaster(8):g' \
+                       "${i}" || die "sed failed" || die "sed failed"
+       done
+       mv man/master.8 man/cyrusmaster.8 || die "mv failed"
+       sed -i -e "s:MASTER:CYRUSMASTER:g" \
+               -e "s:Master:Cyrusmaster:g" \
+               -e "s:master:cyrusmaster:g" \
+               man/cyrusmaster.8 || die "sed failed"
+
+       # do not strip
+       sed -i -e '/(INSTALL/s/-s //' "${S}"/imtest/Makefile.in
+
+       # correct afs include and liblwp.a directory
+       sed -i -e '/I${with_afs_incdir/s/\/include//' \
+               -e '/liblwp/s/liblwp/afs\/liblwp/' \
+               "${S}"/configure{,.in} || die
+       # same with lock.h
+       sed -i -e '/lock.h/s:lock.h:afs/lock.h:' \
+               ptclient/afskrb.c || die
+       # libcom_err.a to libafscom_err.a
+       sed -i -e '/afs\/libcom_err.a/s:libcom_err.a:libafscom_err.a:' \
+               configure{,.in} || die
+}
+
+src_configure() {
+       local myconf
+       if use mysql ; then
+               myconf=$(mysql_config --include)
+               myconf="--with-mysql-incdir=${myconf#-I}"
+       fi
+       if use afs ; then
+               myconf+=" --with-afs-libdir=/usr/$(get_libdir)"
+               myconf+=" --with-afs-incdir=/usr/include/afs"
+       fi
+       if use berkdb ; then
+               myconf+=" --with-bdb-incdir=$(db_includedir)"
+       fi
+       econf \
+               --enable-murder \
+               --enable-netscapehack \
+               --enable-idled \
+               --with-service-path=/usr/$(get_libdir)/cyrus \
+               --with-cyrus-user=cyrus \
+               --with-cyrus-group=mail \
+               --with-com_err=yes \
+               --with-sasl \
+               --without-perl \
+               --without-krb \
+               --without-krbdes \
+               --with-zlib \
+               $(use_enable afs) \
+               $(use_enable afs krb5afspts) \
+               $(use_with berkdb bdb) \
+               $(use_enable nntp) \
+               $(use_enable replication) \
+               $(use_enable kerberos gssapi) \
+               $(use_with mysql) \
+               $(use_with postgres pgsql) \
+               $(use_with sqlite) \
+               $(use_with ssl openssl) \
+               $(use_enable sieve) \
+               $(use_with snmp) \
+               $(use_with tcpd libwrap) \
+               ${myconf}
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+
+       # file collision - bug #368245
+       if ! use nntp ; then
+               rm "${D}"/usr/share/man/man8/fetchnews.8*
+       fi
+
+       dodoc README*
+       dohtml doc/*.html doc/murder.png
+       docinto text
+       dodoc doc/text/*
+       cp doc/cyrusv2.mc "${D}/usr/share/doc/${PF}/html"
+       cp -r contrib tools "${D}/usr/share/doc/${PF}"
+       rm -f doc/text/Makefile*
+
+       insinto /etc
+       doins "${FILESDIR}/cyrus.conf" "${FILESDIR}/imapd.conf"
+
+       # turn off sieve if not installed
+       if ! use sieve; then
+               sed -i -e "/sieve/s/^/#/" "${D}/etc/cyrus.conf" || die
+       fi
+
+       newinitd "${FILESDIR}/cyrus.rc6" cyrus
+       newconfd "${FILESDIR}/cyrus.confd" cyrus
+       newpamd "${FILESDIR}/cyrus.pam-include" sieve
+
+       for subdir in imap/{,db,log,msg,proc,socket,sieve} spool/imap/{,stage.} ; do
+               keepdir "/var/${subdir}"
+               fowners cyrus:mail "/var/${subdir}"
+               fperms 0750 "/var/${subdir}"
+       done
+       for subdir in imap/{user,quota,sieve} spool/imap ; do
+               for i in a b c d e f g h i j k l m n o p q r s t v u w x y z ; do
+                       keepdir "/var/${subdir}/${i}"
+                       fowners cyrus:mail "/var/${subdir}/${i}"
+                       fperms 0750 "/var/${subdir}/${i}"
+               done
+       done
+}
+
+pkg_postinst() {
+       # do not install server.{key,pem) if they exist.
+       if use ssl ; then
+               if [ ! -f "${ROOT}"etc/ssl/cyrus/server.key ]; then
+                       install_cert /etc/ssl/cyrus/server
+                       chown cyrus:mail "${ROOT}"etc/ssl/cyrus/server.{key,pem}
+               fi
+       fi
+
+       elog "For correct logging add the following to /etc/syslog.conf:"
+       elog "    local6.*         /var/log/imapd.log"
+       elog "    auth.debug       /var/log/auth.log"
+       echo
+
+       elog "You have to add user cyrus to the sasldb2. Do this with:"
+       elog "    saslpasswd2 cyrus"
+}