net-fs/samba: Added 4.3.0 version (build fails with system heimdal).
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 8 Sep 2015 22:20:04 +0000 (00:20 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 8 Sep 2015 22:23:24 +0000 (00:23 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-fs/samba/Manifest
net-fs/samba/samba-4.3.0.ebuild [new file with mode: 0644]

index e1c4307e1c5430c918985a88f7e5a581db9f21e1..fd615b9e5fdbd7f61598c8a7fbb9ffbd19326bfd 100644 (file)
@@ -6,4 +6,5 @@ DIST samba-4.1.19.tar.gz 19558250 SHA256 62f23dffacd4faf8ac557f9cf01a1595e39db0b
 DIST samba-4.1.20.tar.gz 19561057 SHA256 adcf021c2ee7ebdba99ed90bb06e45bcc8e3fd9419667622704276607b832038 SHA512 abdd696bb19ac458f72304208d62c21f0fee5459b9f8c4241e4cd8c1654e07455c0876013236a10296ba7ef72a7fca3de0bb6e1cd9d03817500720fb493b1988 WHIRLPOOL 48302e865be9860db7775ad864e30b4ca4bc30f9e791d529353b67e29bec79a11e1409e4b59a974111171927d73193fec46ae1dc40197e5a72ade775e82cd41d
 DIST samba-4.2.3.tar.gz 20721283 SHA256 b6dfa5ae4818d891ee2fcff04a5912f4a4fb2394b4f5e66a2a15b428da094c7c SHA512 33fd4deb3a9bb6ee7656fb716116f2ff3c65303ce7c13bdf2c4c618ce67e61f1d1fa77c7c29504e4bb4d6c5a094dcc54dc41999864e52ebd521d89a93666383a WHIRLPOOL 0684eae6fa815f3af99646721fd414e57e26966cc30b8c0e12bd8a1e651ac7984855521044b83becfd2beb70c5820d49d3dd1e702bb78109b34ec188b0e43191
 DIST samba-4.2.4.tar.gz 20735687 SHA256 fb326ea486973ab684f183774e93bb943fc231ab89937512e70331b86acdf6ae SHA512 a389fb2540858b778677197f01b5e2aa90c85c28e008d2f8e13a422cbf00a19ce862320b57b8141bd7838f74cbd4641efbe030c0fc2d86058f6584f9f8504d2f WHIRLPOOL 90dffe178647233fc8dec9b9ac15c7864f1700fc2aa739f24e33714e81f04ed364f6837ec95827a8ed6af6c7646e1b0eca83f22eaf196706ad9ea1ef8f425635
+DIST samba-4.3.0.tar.gz 20417699 SHA256 d8dbb6b29dec1d9aa295655c4aa4eadd1e5367ef7047be22f4d6a18ba8acdb63 SHA512 7edad171dd98a332ebfd51c7c380b1def3d1508399755fc2d333671ce4a7d5e73782871c5760341cb71460d3f7fc4b666d906d61b9e2b28f977301d08bc9a872 WHIRLPOOL cd204bb122cc344b63b01aebc151aeb01e533402eb511ba7c440fc718a568f8004f754a4502c74dfd58869e2e22cfd0f9822c2602e3642da5b69d2bdd2b76d39
 DIST smb_traffic_analyzer_v2.diff.bz2 12226 SHA256 1bae7eafbe8ac2382313d5ab9d43d73ba64b63a714f0f588516952d476fb868d SHA512 aa0e457a0dd282e61e6dfcd5705c29b319832dca9711b1b5baf8373e2f079991399c3537c050219ccb861a93f86353ebff677a5c625d2e3f1f3a13ee5c4087d0 WHIRLPOOL 85ee72a360f67ebe71be5cd400ecd635280a0d7c64ebb8b94656a5ef1a94f74a987de86408af00ce1b81cc8363b1b3cf14726860d29b72ee610d4bab73d6b139
diff --git a/net-fs/samba/samba-4.3.0.ebuild b/net-fs/samba/samba-4.3.0.ebuild
new file mode 100644 (file)
index 0000000..9069a4a
--- /dev/null
@@ -0,0 +1,186 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit python-single-r1 waf-utils multilib linux-info systemd eutils
+
+MY_PV="${PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+SRC_PATH="stable"
+[[ ${PV} = *_rc* ]] && SRC_PATH="rc"
+
+SRC_URI="mirror://samba/${SRC_PATH}/${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~hppa ~x86"
+[[ ${PV} = *_rc* ]] && KEYWORDS=""
+
+DESCRIPTION="Samba Suite Version 4"
+HOMEPAGE="http://www.samba.org/"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+IUSE="acl addns ads aio avahi client cluster cups dmapi fam gnutls iprint
+ldap quota selinux syslog systemd test winbind"
+
+# sys-apps/attr is an automagic dependency (see bug #489748)
+# sys-libs/pam is an automagic dependency (see bug #489770)
+CDEPEND="${PYTHON_DEPS}
+       >=app-crypt/heimdal-1.5[-ssl]
+       dev-libs/iniparser:0
+       dev-libs/popt
+       sys-libs/readline:=
+       virtual/libiconv
+       dev-python/subunit[${PYTHON_USEDEP}]
+       >=net-libs/socket_wrapper-1.1.2
+       sys-apps/attr
+       sys-libs/libcap
+       >=sys-libs/ldb-1.1.20
+       sys-libs/ncurses:0=
+       >=sys-libs/nss_wrapper-1.0.2
+       >=sys-libs/talloc-2.1.2[python,${PYTHON_USEDEP}]
+       >=sys-libs/tdb-1.3.6[python,${PYTHON_USEDEP}]
+       >=sys-libs/tevent-0.9.25
+       >=sys-libs/uid_wrapper-1.0.1
+       sys-libs/zlib
+       virtual/pam
+       acl? ( virtual/acl )
+       addns? ( net-dns/bind-tools[gssapi] )
+       aio? ( dev-libs/libaio )
+       cluster? ( >=dev-db/ctdb-1.0.114_p1 )
+       cups? ( net-print/cups )
+       dmapi? ( sys-apps/dmapi )
+       fam? ( virtual/fam )
+       gnutls? ( dev-libs/libgcrypt:0
+               >=net-libs/gnutls-1.4.0 )
+       ldap? ( net-nds/openldap )
+       systemd? ( sys-apps/systemd:0= )"
+DEPEND="${CDEPEND}
+       virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+       client? ( net-fs/cifs-utils[ads?] )
+       selinux? ( sec-policy/selinux-samba )
+"
+
+REQUIRED_USE="ads? ( acl gnutls ldap )
+       ${PYTHON_REQUIRED_USE}"
+
+RESTRICT="mirror"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/${PN}-4.2.3-heimdal_compilefix.patch" )
+
+CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+       python-single-r1_pkg_setup
+       if use aio; then
+               if ! linux_config_exists || ! linux_chkconfig_present AIO; then
+                               ewarn "You must enable AIO support in your kernel config, "
+                               ewarn "to be able to support asynchronous I/O. "
+                               ewarn "You can find it at"
+                               ewarn
+                               ewarn "General Support"
+                               ewarn " Enable AIO support "
+                               ewarn
+                               ewarn "and recompile your kernel..."
+               fi
+       fi
+}
+
+src_prepare() {
+       epatch ${PATCHES[@]}
+}
+
+src_configure() {
+       local myconf=''
+       use "cluster" && myconf+=" --with-ctdb-dir=/usr"
+       use "test" && myconf+=" --enable-selftest"
+       myconf="${myconf} \
+               --enable-fhs \
+               --sysconfdir=/etc \
+               --localstatedir=/var \
+               --with-modulesdir=/usr/$(get_libdir)/samba \
+               --with-pammodulesdir=/$(get_libdir)/security \
+               --with-piddir=/var/run/${PN} \
+               --disable-rpath \
+               --disable-rpath-install \
+               --nopyc \
+               --nopyo \
+               --bundled-libraries=NONE \
+               --builtin-libraries=NONE \
+               $(use_with addns dnsupdate) \
+               $(use_with acl acl-support) \
+               $(use_with ads) \
+               $(use_with aio aio-support) \
+               $(use_enable avahi) \
+               $(use_with cluster cluster-support) \
+               $(use_enable cups) \
+               $(use_with dmapi) \
+               $(use_with fam) \
+               $(use_enable gnutls) \
+               $(use_enable iprint) \
+               $(use_with ldap) \
+               --with-pam \
+               --with-pam_smbpass \
+               $(use_with quota quotas) \
+               $(use_with syslog) \
+               $(use_with systemd) \
+               $(use_with winbind)
+               "
+       use "ads" && myconf+=" --with-shared-modules=idmap_ad"
+
+       CPPFLAGS="-I${SYSROOT}/usr/include/et ${CPPFLAGS}" \
+               waf-utils_src_configure ${myconf}
+}
+
+src_install() {
+       waf-utils_src_install
+
+       # install ldap schema for server (bug #491002)
+       if use ldap ; then
+               insinto /etc/openldap/schema
+               doins examples/LDAP/samba.schema
+       fi
+
+       # Make all .so files executable
+       find "${D}" -type f -name "*.so" -exec chmod +x {} +
+
+       # install example config file
+       insinto /etc/samba
+       doins examples/smb.conf.default
+
+       # Install init script and conf.d file
+       newinitd "${CONFDIR}/samba4.initd-r1" samba
+       newconfd "${CONFDIR}/samba4.confd" samba
+
+       systemd_dotmpfilesd "${FILESDIR}"/samba.conf
+       systemd_dounit "${FILESDIR}"/nmbd.service
+       systemd_dounit "${FILESDIR}"/smbd.{service,socket}
+       systemd_newunit "${FILESDIR}"/smbd_at.service 'smbd@.service'
+       systemd_dounit "${FILESDIR}"/winbindd.service
+       systemd_dounit "${FILESDIR}"/samba.service
+}
+
+src_test() {
+       "${WAF_BINARY}" test || die "test failed"
+}
+
+pkg_postinst() {
+       ewarn "Be aware the this release contains the best of all of Samba's"
+       ewarn "technology parts, both a file server (that you can reasonably expect"
+       ewarn "to upgrade existing Samba 3.x releases to) and the AD domain"
+       ewarn "controller work previously known as 'samba4'."
+
+       elog "For further information and migration steps make sure to read "
+       elog "http://samba.org/samba/history/${P}.html "
+       elog "http://samba.org/samba/history/${PN}-4.2.0.html and"
+       elog "http://wiki.samba.org/index.php/Samba4/HOWTO "
+}