dev-perl/Net-SSH2: add libressl support
authorJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 14:53:06 +0000 (16:53 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Sun, 20 Sep 2015 16:38:02 +0000 (18:38 +0200)
dev-perl/Net-SSH2/Net-SSH2-0.530.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Net-SSH2/Net-SSH2-0.530.0-r1.ebuild b/dev-perl/Net-SSH2/Net-SSH2-0.530.0-r1.ebuild
new file mode 100644 (file)
index 0000000..ba31c41
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RKITOVER
+MODULE_VERSION=0.53
+inherit perl-module
+
+DESCRIPTION="Net::SSH2 - Support for the SSH 2 protocol via libssh2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gcrypt libressl"
+
+RDEPEND="
+       sys-libs/zlib
+       net-libs/libssh2
+       !gcrypt? (
+               !libressl? ( dev-libs/openssl:0 )
+               libressl? ( dev-libs/libressl )
+       )
+       gcrypt? (
+               dev-libs/libgcrypt:0
+       )
+"
+DEPEND="${RDEPEND}
+       >=virtual/perl-ExtUtils-MakeMaker-6.50
+"
+
+SRC_TEST="do"
+
+src_configure() {
+       use gcrypt && myconf=gcrypt
+       perl-module_src_configure
+}