media-video/mkclean: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 13:20:37 +0000 (14:20 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 13 Dec 2019 13:20:37 +0000 (14:20 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-video/mkclean/mkclean-0.8.10.ebuild

index c094af08ab56482f3b6ee84c93a837c57da86fef..35ddf2b4dfca6401824ae3c018409061447a1a18 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=7
 
 inherit toolchain-funcs
 
@@ -12,7 +12,6 @@ SRC_URI="http://downloads.sourceforge.net/project/matroska/${PN}/${P}.tar.bz2"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE=""
 
 src_configure() {
        tc-export CC CXX
@@ -23,8 +22,13 @@ src_configure() {
        ./coremake $(corec/tools/coremake/system_output.sh) || die
 
        # fixing generated makefiles
-       sed -i -e 's|^\(LFLAGS.*+=.*\$(LIBS)\)|\1 \$(LDFLAGS)|g' \
-               -e 's|^\(STRIP.*=\)|\1 echo|g' $(find -name "*.mak") || die
+       local f
+       while IFS="" read -d $'\0' -r f; do
+               sed \
+                       -e 's|^\(LFLAGS.*+=.*\$(LIBS)\)|\1 \$(LDFLAGS)|g' \
+                       -e 's|^\(STRIP.*=\)|\1 echo|g' \
+                       -i "${f}" || die
+       done < <(find -name "*.mak" -type f -print0)
 }
 
 src_compile() {