sci-mathematics/slepc: version bump to 3.13.1; remove old
authorMatthias Maier <tamiko@gentoo.org>
Wed, 29 Apr 2020 21:15:26 +0000 (16:15 -0500)
committerMatthias Maier <tamiko@gentoo.org>
Wed, 29 Apr 2020 21:35:40 +0000 (16:35 -0500)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
sci-mathematics/slepc/Manifest
sci-mathematics/slepc/slepc-3.12.1.ebuild [deleted file]
sci-mathematics/slepc/slepc-3.13.1.ebuild [moved from sci-mathematics/slepc/slepc-3.11.1.ebuild with 84% similarity]

index d23b2beb677f4f9e1630b68351a96635793024e6..9beac5e49658fa99c11ffa25d320fc149e416020 100644 (file)
@@ -1,2 +1 @@
-DIST slepc-3.11.1.tar.gz 4700643 BLAKE2B a624050aad0128d7ef53f27f72484e078e62d8edf9298995dda71a9e8d804dddc7e433542eccf95b2d896be80e8795b1664375e68a4c02c18c56d78d490bffb7 SHA512 a941c2a955953ed2344de7f7d9eaaed79504c3559e27920c633bc09cfb192f883b26fd4aa5dc3bd9909a2fc045f3a34e514feca0e074ca36bc3166aa9c059235
-DIST slepc-3.12.1.tar.gz 4757436 BLAKE2B 607e7b28730ff16fa995768e23fd9861e180c078d2f06e8f65324b1e1761f0688fe5a4c4420983b521583cb2b3fe28b606baea604daf5253c30131f9f54c5572 SHA512 0254ea1a521cf150f9f0402bb936c9d1aa32765264e055ecdd058e44aaa7e87c3df1b63b1889c1989c4a691c652eb0f248a1bbbe6d555ce16f9f8f28d6765b50
+DIST slepc-3.13.1.tar.gz 4797627 BLAKE2B 29372b8a2d4c5f3b26e840df743f7aec098bfeeb29e9c108e509baa21d9697da19c737470ba4c132391d5193ebf749ef3f3c6ece600ec7527502d40a239aa0ee SHA512 620c344274808329c0a1009e7844532e03e88d38135bfd5b73bc0bc6815b17b6dfb49341d05399230ba6e06997db688aec17615429eaca3dc94fd886119bf321
diff --git a/sci-mathematics/slepc/slepc-3.12.1.ebuild b/sci-mathematics/slepc/slepc-3.12.1.ebuild
deleted file mode 100644 (file)
index 52212ca..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils flag-o-matic python-any-r1 toolchain-funcs
-
-DESCRIPTION="Scalable Library for Eigenvalue Problem Computations"
-HOMEPAGE="http://slepc.upv.es/"
-SRC_URI="http://slepc.upv.es/download/distrib/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="complex-scalars doc mpi"
-
-RDEPEND="
-       =sci-mathematics/petsc-$(ver_cut 1-2)*:=[mpi=,complex-scalars=]
-       sci-libs/arpack[mpi=]
-       mpi? ( virtual/mpi )
-"
-
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       virtual/pkgconfig
-       dev-util/cmake
-"
-
-MAKEOPTS="${MAKEOPTS} V=1"
-
-src_prepare() {
-       default
-
-       sed -i -e 's%/usr/bin/env python%/usr/bin/env python2%' configure || die
-}
-
-src_configure() {
-       # *sigh*
-       addpredict "${PETSC_DIR}"/.nagged
-
-       # Make sure that the environment is set up correctly:
-       unset PETSC_DIR
-       unset PETSC_ARCH
-       unset SLEPC_DIR
-       source "${EPREFIX}"/etc/env.d/99petsc
-       export PETSC_DIR
-
-       # configure is a custom python script and doesn't want to have default
-       # configure arguments that we set with econf
-       ./configure \
-               --prefix="${EPREFIX}/usr/$(get_libdir)/slepc" \
-               --with-arpack=1 \
-               --with-arpack-dir="${EPREFIX}/usr/$(get_libdir)" \
-               --with-arpack-flags="$(usex mpi "-lparpack,-larpack" "-larpack")"
-
-}
-
-src_install() {
-       emake DESTDIR="${ED}" install
-
-       # add PETSC_DIR to environmental variables
-       cat >> 99slepc <<- EOF
-               SLEPC_DIR=${EPREFIX}/usr/$(get_libdir)/slepc
-               LDPATH=${EPREFIX}/usr/$(get_libdir)/slepc/lib
-       EOF
-       doenvd 99slepc
-
-       if use doc ; then
-               dodoc docs/slepc.pdf
-               docinto html
-               dodoc -r docs/*.html docs/manualpages
-       fi
-}
similarity index 84%
rename from sci-mathematics/slepc/slepc-3.11.1.ebuild
rename to sci-mathematics/slepc/slepc-3.13.1.ebuild
index 52212cabfd52646cc15f5f7b392f959dc6104251..be2d085dd6cb0fcda1280689d2251b453bbd2913 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6,7,8} )
 
 inherit eutils flag-o-matic python-any-r1 toolchain-funcs
 
@@ -30,12 +30,6 @@ DEPEND="${RDEPEND}
 
 MAKEOPTS="${MAKEOPTS} V=1"
 
-src_prepare() {
-       default
-
-       sed -i -e 's%/usr/bin/env python%/usr/bin/env python2%' configure || die
-}
-
 src_configure() {
        # *sigh*
        addpredict "${PETSC_DIR}"/.nagged
@@ -43,9 +37,10 @@ src_configure() {
        # Make sure that the environment is set up correctly:
        unset PETSC_DIR
        unset PETSC_ARCH
-       unset SLEPC_DIR
        source "${EPREFIX}"/etc/env.d/99petsc
        export PETSC_DIR
+       export PETSC_ARCH
+       export SLEPC_DIR="${S}"
 
        # configure is a custom python script and doesn't want to have default
        # configure arguments that we set with econf
@@ -53,8 +48,7 @@ src_configure() {
                --prefix="${EPREFIX}/usr/$(get_libdir)/slepc" \
                --with-arpack=1 \
                --with-arpack-dir="${EPREFIX}/usr/$(get_libdir)" \
-               --with-arpack-flags="$(usex mpi "-lparpack,-larpack" "-larpack")"
-
+               --with-arpack-lib="$(usex mpi "-lparpack,-larpack" "-larpack")"
 }
 
 src_install() {