net-analyzer/cacti: Version 1.2.10
authorJeroen Roovers <jer@gentoo.org>
Mon, 2 Mar 2020 08:59:30 +0000 (09:59 +0100)
committerJeroen Roovers <jer@gentoo.org>
Tue, 10 Mar 2020 08:22:27 +0000 (09:22 +0100)
Package-Manager: Portage-2.3.90, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-analyzer/cacti/Manifest
net-analyzer/cacti/cacti-1.2.10.ebuild [new file with mode: 0644]

index c078ee6222791ae7a14a1062bd39cee628836888..bd9cd26e9d18b535cbcf371cb54652dda4d2523d 100644 (file)
@@ -1 +1,2 @@
+DIST cacti-1.2.10.tar.gz 24907181 BLAKE2B 7e3e95e531022fb0a49dd951464608860de19e5ab158424ce8daef5b5ac975468f5864acf831b821e83877a17f8310be16f4179afa89bc9d34c4d8d80e9933c4 SHA512 8ed9bd895dc5763fabc20e4fb3c78eb2f520b05fca03b6aac843860402cf15e754af1eb9d65412ed10db6e93531806d1ef48957a08f56f2f8b40f235b4413cf3
 DIST cacti-1.2.9.tar.gz 24906227 BLAKE2B 65a4459f9f55c55db853f81bcac6c60f146ba50f6dfd0abde449a41847afdb8564452ede1a493291c19ee7732ccc4a76d485af078021c7e0fcb6d1b265994940 SHA512 e50eb5587dc0274788b35cb701383ba897ab7c45a65efc7a8d32963b492c1ff1b96b0271ab7b6f9b53ad7dff5dd66b3ce4bd4a91c3ecf8ccd8d4b19b3ac972e4
diff --git a/net-analyzer/cacti/cacti-1.2.10.ebuild b/net-analyzer/cacti/cacti-1.2.10.ebuild
new file mode 100644 (file)
index 0000000..66775ef
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils webapp
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="https://www.cacti.net/"
+SRC_URI="https://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp doc"
+
+need_httpd
+
+RDEPEND="
+       dev-lang/php[cli,mysql,pdo,session,sockets,xml]
+       dev-php/adodb
+       net-analyzer/rrdtool[graph]
+       virtual/cron
+       snmp? ( >=net-analyzer/net-snmp-5.2.0 )
+"
+
+src_compile() { :; }
+
+src_install() {
+       dodoc CHANGELOG
+       dodoc -r docs
+       mv docs .. || die
+
+       webapp_src_preinst
+
+       edos2unix `find -type f -name '*.php'`
+
+       dodir ${MY_HTDOCSDIR}
+       cp -r . "${D}"${MY_HTDOCSDIR}
+
+       webapp_serverowned ${MY_HTDOCSDIR}/rra
+       webapp_serverowned ${MY_HTDOCSDIR}/log
+       webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+       webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+       webapp_src_install
+}