dev-python/python-ldap: Drop old
authorJustin Lecher <jlec@gentoo.org>
Mon, 21 Sep 2015 12:00:42 +0000 (14:00 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 21 Sep 2015 12:10:45 +0000 (14:10 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/python-ldap/Manifest
dev-python/python-ldap/python-ldap-2.4.15.ebuild [deleted file]

index 7c6f3bf95f78afe0c84e83513e87de1c66ff6ed1..d50a32aacd3a1a12efa7b892c88e5efe6ece9f89 100644 (file)
@@ -1,3 +1,2 @@
-DIST python-ldap-2.4.15.tar.gz 111597 SHA256 30bcac33ded943557fbafb1b6d9c345deab34d89d63dbcee9e6b59207db11670 SHA512 2e2d5ecc4f96a63465dbc0da3b8a524729cf199f95eb559beeea5466da4fa9667f61aff7e482f73d6581d24477cb4780fccd599619fbb92b2810bdc81f2de310 WHIRLPOOL c3c3135a2b073cc74d2692df0b9d0baaf8353ce253619747fb0626fa34b3f6df8dde184894856b934b63666c413aed81e80f3321893539d1825660a1f75b1be6
 DIST python-ldap-2.4.19.tar.gz 138503 SHA256 02fddb3accbfb54e40ff47a59457e422b253f9fb6cd64bb3851b349295fab048 SHA512 bfa8b87449f03d70d78bf890d1190ef5a153e1b84db97ca4b40465bfba9faedace2a69f4ae1279ef6323c01255f52993cf0e4374bc32d9660a5286dfc7c17b85 WHIRLPOOL 708c6744b41fc4c9dc4473a9ab088016aa722f5b196c080973fedbb07a08dd57f859ddb5d193665349f44d2d08ff9e2f797cfa6af23e34624f1d0a9e21d62d4d
 DIST python-ldap-2.4.20.tar.gz 142355 SHA256 4b8891539a3171d993cf7896b632ff088a4c707ae85ac3c77db1454f7949f3e2 SHA512 d8afe217c18d49b70089bc47bac7c48f57774b78b1dd44ae3a60e669a3df59058d8579b9de64a2349af612db8e3c1ea5bfa5a47148c651cbfa4038dbc58b9ff2 WHIRLPOOL 562993e84f5c41b3aefd808a047d6cf8ea6c4284171f7f0d858d3a7417a67e31b06f283ed557fbad3fde25a4a9d2c049cbce52c0759b94850ea19848e4192f64
diff --git a/dev-python/python-ldap/python-ldap-2.4.15.ebuild b/dev-python/python-ldap/python-ldap-2.4.15.ebuild
deleted file mode 100644 (file)
index 1d09239..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# setup.py is written only for py2, which suits pypy
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1 multilib
-
-DESCRIPTION="Various LDAP-related Python modules"
-HOMEPAGE="http://www.python-ldap.org https://pypi.python.org/pypi/python-ldap"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-solaris"
-# doc flag dropped due to absence of the docs
-IUSE="examples sasl ssl"
-
-# If you need support for openldap-2.3.x, please use python-ldap-2.3.9.
-# python team: Please do not remove python-ldap-2.3.9 from the tree.
-# OpenSSL is an optional runtime dep.
-RDEPEND=">net-nds/openldap-2.4.11
-       dev-python/pyasn1[${PYTHON_USEDEP}]
-       sasl? ( >=dev-libs/cyrus-sasl-2.1 )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       sed -e "s:^library_dirs =.*:library_dirs = /usr/$(get_libdir) /usr/$(get_libdir)/sasl2:" \
-               -e "s:^include_dirs =.*:include_dirs = ${EPREFIX}/usr/include ${EPREFIX}/usr/include/sasl:" \
-               -i setup.cfg || die "error fixing setup.cfg"
-
-       local mylibs="ldap"
-       if use sasl; then
-               use ssl && mylibs="ldap_r"
-               mylibs="${mylibs} sasl2"
-       else
-               sed -e 's/HAVE_SASL//g' -i setup.cfg || die
-       fi
-       use ssl && mylibs="${mylibs} ssl crypto"
-       use elibc_glibc && mylibs="${mylibs} resolv"
-
-       sed -e "s:^libs = .*:libs = lber ${mylibs}:" \
-               -i setup.cfg || die "error setting up libs in setup.cfg"
-
-       # set test expected to fail to expectedFailure
-       sed -e "s:^    def test_bad_urls:    @unittest.expectedFailure\n    def test_bad_urls:" \
-               -i Tests/t_ldapurl.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       # XXX: the tests supposedly can start local slapd
-       # but it requires some manual config, it seems.
-
-       "${PYTHON}" Tests/t_ldapurl.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
-       use examples && local EXAMPLES=( Demo/. )
-       distutils-r1_python_install_all
-}