gnome-extra/gnome-shell-extension-dash-to-panel: Version bump to v25
authorPacho Ramos <pacho@gentoo.org>
Sun, 10 Nov 2019 12:30:58 +0000 (13:30 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 10 Nov 2019 12:35:53 +0000 (13:35 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
gnome-extra/gnome-shell-extension-dash-to-panel/Manifest
gnome-extra/gnome-shell-extension-dash-to-panel/gnome-shell-extension-dash-to-panel-25.ebuild [new file with mode: 0644]

index 1f7a865dc225e8dd9d648a191d21831da4cb43a7..95155856a37857e5a661ab92e8359b340adf0ac7 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-shell-extension-dash-to-panel-23.tar.gz 21075058 BLAKE2B 66a48a2ca1379fb423fbd55e68b13dc8e649aceb89676d80893b56e6bda860937946bc981bca110634c975c8712378e5dbdc67f5749a4f5aa70622b75304b71b SHA512 0f8ea1b5b92213046195e88cd6433f15cf05d73712c88def4ffcfe43e75e8fad11df5a25a2b4e2ace9ac0e4b56c151e20931cfa233c39589ee33d1fec1a8499a
+DIST gnome-shell-extension-dash-to-panel-25.tar.gz 21097782 BLAKE2B 25061645ecfe073b3891a974c765a98df295daa01a82cac53318b505bea99296ceddac91898fdae7fe1e01f8042d665f39d5c600544fcc69b9911a7078ed3de6 SHA512 7675fa8f1d73981fcb1e7347d0664851bf7ebb0b467093b1a166470b91890623ae617ba6399e8f367c56e84d293625cf75aca2b8f17ac21fbd96243a22e216c7
diff --git a/gnome-extra/gnome-shell-extension-dash-to-panel/gnome-shell-extension-dash-to-panel-25.ebuild b/gnome-extra/gnome-shell-extension-dash-to-panel/gnome-shell-extension-dash-to-panel-25.ebuild
new file mode 100644 (file)
index 0000000..853e1e9
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+MY_PN="${PN/gnome-shell-extension-/}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="An icon taskbar for the Gnome Shell"
+HOMEPAGE="https://github.com/home-sweet-gnome/dash-to-panel"
+SRC_URI="https://github.com/home-sweet-gnome/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-libs/glib:2"
+RDEPEND="${COMMON_DEPEND}
+       app-eselect/eselect-gnome-shell-extensions
+       >=gnome-base/gnome-shell-3.18.0
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND="
+       dev-util/intltool
+       sys-devel/gettext
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       default
+
+       # Set correct version
+       export VERSION="${PV}"
+
+       # Don't install README and COPYING in unwanted locations
+       sed -i -e 's/COPYING//g' -e 's/README.md//g' Makefile || die
+}
+
+pkg_preinst() {
+       gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+       gnome2_schemas_update
+       ebegin "Updating list of installed extensions"
+       eselect gnome-shell-extensions update
+       eend $?
+}
+
+pkg_postrm() {
+       gnome2_schemas_update
+}