dev-libs/libestr: bump to v0.1.11
authorThomas Deutschmann <whissi@gentoo.org>
Sat, 3 Nov 2018 19:15:15 +0000 (20:15 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 3 Nov 2018 22:42:22 +0000 (23:42 +0100)
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-libs/libestr/Manifest
dev-libs/libestr/libestr-0.1.11.ebuild [new file with mode: 0644]

index 0ecf5cb29003cd7cf732ae25ce7d36841df543fc..ae5c01b438740a6e68ab8e89a9089480252c7f91 100644 (file)
@@ -1 +1,2 @@
 DIST libestr-0.1.10.tar.gz 336122 BLAKE2B 7a157d030415bbdc8c289061c4ce1ddac4fdfd7356e82857afbf9a8d6ff4bee0a0b98f2e39c4adb69a0349c33a29f1cdd90ec901c3501c0fcafb45faecbfea7c SHA512 477b06e2b6ea9b2e34fe0d91328c9191a678b173751e595359c05772db50a4d348ac132bec0c926fba91ceccc013e15cd4cc57a6b734874c06073bf23151bac7
+DIST libestr-0.1.11.tar.gz 355544 BLAKE2B c165212c4a56ee577a76dbb95dfe9d08d84087d490422d4fb7c29cadc5b5d0eed97234369331286433e2d860d3cfa8af3117d3ff94e8833df91f6586905ad2c8 SHA512 0ab98c2fa4b58cf6fee89c88602725b8b5e8e5a171a6976cdd8cff4dfc1cd3e5b747868da74fccd1bca66b9fa524ceae1c4f1ad5ee653a44ff81df6916ab5328
diff --git a/dev-libs/libestr/libestr-0.1.11.ebuild b/dev-libs/libestr/libestr-0.1.11.ebuild
new file mode 100644 (file)
index 0000000..719c5da
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="Library for some string essentials"
+HOMEPAGE="http://libestr.adiscon.com/"
+SRC_URI="http://libestr.adiscon.com/files/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86"
+IUSE="debug static-libs test"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       default
+
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               $(use_enable debug)
+               $(use_enable static-libs static)
+               $(use_enable test testbench)
+       )
+
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       find "${ED%/}"/usr/lib* -name '*.la' -delete || die
+}