dev-java/picocontainer: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 21:00:59 +0000 (22:00 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 9 Nov 2019 21:33:08 +0000 (22:33 +0100)
Closes: https://bugs.gentoo.org/697358
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-java/picocontainer/picocontainer-1.1-r1.ebuild

index a49d6d45238cfc35abd4d485fd68d6ac1c476d4f..426b18e4aeb60fec89e59772cb86a1afdd0a5460 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit java-pkg-2 java-ant-2
 
@@ -25,9 +25,9 @@ DEPEND=">=virtual/jdk-1.4
 
 RESTRICT="test"
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
+src_prepare() {
+       default
+
        # Don't run tests automatically
        sed -i -e 's/compile,test/compile/' build.xml || die