Changes for bug 74929.
authorHasan Khalil <gongloo@gentoo.org>
Thu, 20 Jan 2005 03:48:05 +0000 (03:48 +0000)
committerHasan Khalil <gongloo@gentoo.org>
Thu, 20 Jan 2005 03:48:05 +0000 (03:48 +0000)
Package-Manager: portage-2.0.51-r14

app-arch/cpio/ChangeLog
app-arch/cpio/Manifest
app-arch/cpio/cpio-2.6.ebuild
app-arch/cpio/files/2.6-isnumber.patch [new file with mode: 0644]

index 684afd392685571e6f95ba719bb09f08f57a639d..c3ccf8e8e55e3a6ea1a94c347ec1f6350c4b4362 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-arch/cpio
 # Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.9 2005/01/20 00:03:31 gongloo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/ChangeLog,v 1.10 2005/01/20 03:48:05 gongloo Exp $
+
+  19 Jan 2005; <gongloo@gentoo.org> +files/2.6-isnumber.patch,
+  cpio-2.6.ebuild:
+  Added doman ${D}/usr/share/man/man1/cpio.1 to properly handle manpage
+  gzipping. Added isnumber patch, replacing isnumber by cpio_isnumber (for
+  compatibility reasons). Closes bug 74929.
 
   19 Jan 2005; <gongloo@gentoo.org> cpio-2.5.ebuild:
   Stable on ppc-macos.
index f31ecbcf9e3d86ea33501d6e94d3a382d5112f35..6fff8c94f1a1dc6b5b5600fccaa1dee4cb5948b2 100644 (file)
@@ -1,7 +1,8 @@
-MD5 5367fddbe98fa0cad819922216bbb666 ChangeLog 3272
+MD5 a910ca639df3a148916738147c33a306 ChangeLog 3547
 MD5 ca553fdcf418df4fac0aa9000c76b9d1 cpio-2.5.ebuild 797
-MD5 d58f1c341c15df1983c45b0ba94586db cpio-2.6.ebuild 921
+MD5 2162647d825c9f380cf4413c34172ac8 cpio-2.6.ebuild 1001
 MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
 MD5 a0838e9d5ff0463ecb8758db81652ff1 files/digest-cpio-2.5 60
 MD5 76f4688893a4a9b394442da68fbf0d5e files/2.6-rili-big-files.patch 2566
 MD5 898f15e2e1a554916e69e9397f130e81 files/digest-cpio-2.6 61
+MD5 b8e4b9cc188354bdbae9b43dfcc0ecfe files/2.6-isnumber.patch 709
index 6e0c9d41b6a2b73e34c714ce2b86310b4d6ba6a0..c9bff5d02698a58c9e007bda21aeaa81670cd024 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2005 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.6.ebuild,v 1.1 2005/01/04 02:26:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/cpio/cpio-2.6.ebuild,v 1.2 2005/01/20 03:48:05 gongloo Exp $
 
 inherit eutils
 
@@ -19,6 +19,7 @@ src_unpack() {
        unpack ${A}
        cd ${S}
        epatch ${FILESDIR}/${PV}-rili-big-files.patch
+       epatch ${FILESDIR}/${PV}-isnumber.patch
 }
 
 src_compile() {
@@ -33,6 +34,7 @@ src_compile() {
 src_install() {
        make install DESTDIR="${D}" || die
        dodoc ChangeLog NEWS README INSTALL
+       doman ${D}/usr/share/man/man1/cpio.1
        rm -f "${D}"/usr/share/man/man1/mt.1
        rmdir "${D}"/usr/libexec
 }
diff --git a/app-arch/cpio/files/2.6-isnumber.patch b/app-arch/cpio/files/2.6-isnumber.patch
new file mode 100644 (file)
index 0000000..08a63a9
--- /dev/null
@@ -0,0 +1,30 @@
+diff -uNr cpio-2.5.90.orig/src/userspec.c cpio-2.5.90/src/userspec.c
+--- cpio-2.5.90.orig/src/userspec.c    Wed Dec 29 13:51:30 2004
++++ cpio-2.5.90/src/userspec.c Wed Dec 29 13:52:13 2004
+@@ -72,7 +72,7 @@
+    otherwise return 0. */
+ static int
+-isnumber (const char *str)
++cpio_isnumber (const char *str)
+ {
+   for (; *str; str++)
+     if (!isdigit (*str))
+@@ -136,7 +136,7 @@
+       if (pwd == NULL)
+       {
+-        if (!isnumber (u))
++        if (!cpio_isnumber (u))
+           error_msg = _("invalid user");
+         else
+           {
+@@ -182,7 +182,7 @@
+       grp = getgrnam (g);
+       if (grp == NULL)
+       {
+-        if (!isnumber (g))
++        if (!cpio_isnumber (g))
+           error_msg = _("invalid group");
+         else
+           *gid = atoi (g);