dev-util/rr: tweak build for glibc-2.30, bug #699886
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 12 Nov 2019 07:53:07 +0000 (07:53 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Tue, 12 Nov 2019 07:53:21 +0000 (07:53 +0000)
The build failed as:
```
tgkill.c:7:12: error: static declaration of ‘tgkill’
  follows non-static declaration
    7 | static int tgkill(int tgid, int tid, int sig) {
      |            ^~~~~~
```

Backport upstream glibc-2.30 fix as-is.

Reported-by: Toralf Förster
Closes: https://bugs.gentoo.org/699886
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-util/rr/files/rr-5.2.0-tgkill-glibc-2.30.patch [new file with mode: 0644]
dev-util/rr/rr-5.2.0-r1.ebuild

diff --git a/dev-util/rr/files/rr-5.2.0-tgkill-glibc-2.30.patch b/dev-util/rr/files/rr-5.2.0-tgkill-glibc-2.30.patch
new file mode 100644 (file)
index 0000000..2a6e9da
--- /dev/null
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/699886
+
+From 7044c5c6a8e64c737ba3cdb97187ff5c406e5162 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Emilio=20Cobos=20=C3=81lvarez?= <emilio@crisal.io>
+Date: Thu, 23 May 2019 23:18:26 +0200
+Subject: [PATCH] Fix build in newer glibc.
+
+Seems tgkill was added recently to glibc.
+
+build/32/tgkill.c:7:12: error: static declaration of 'tgkill' follows non-static declaration
+static int tgkill(int tgid, int tid, int sig) {
+           ^
+/usr/include/bits/signal_ext.h:29:12: note: previous declaration is here
+extern int tgkill (__pid_t __tgid, __pid_t __tid, int __signal);
+---
+ src/test/tgkill.c | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+--- a/src/test/tgkill.c
++++ b/src/test/tgkill.c
+@@ -4,9 +4,8 @@
+ static int num_signals_caught;
+-static int tgkill(int tgid, int tid, int sig) {
+-  return syscall(SYS_tgkill, tgid, tid, sig);
+-}
++#define tgkill(tgid, tid, sig) \
++  syscall(SYS_tgkill, (int)(tgid), (int)(tid), (int)(sig))
+ static void sighandler(int sig) {
+   atomic_printf("Task %d got signal %d\n", sys_gettid(), sig);
+-- 
+2.24.0
+
index aae1bb6569fd7bc296febd11fc2b1a918c3c3844..b621d7b200924a93080498eda660e546edc088ef 100644 (file)
@@ -36,6 +36,7 @@ RESTRICT="!test? ( test )"
 PATCHES=(
        "${FILESDIR}"/${P}-ucontext_t.patch
        "${FILESDIR}"/${P}-c++14.patch
+       "${FILESDIR}"/${P}-tgkill-glibc-2.30.patch
 )
 
 pkg_setup() {