dev-vcs/cvs-fast-export: bump up to 1.52
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 10 Apr 2020 12:00:50 +0000 (13:00 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 10 Apr 2020 12:00:50 +0000 (13:00 +0100)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-vcs/cvs-fast-export/Manifest
dev-vcs/cvs-fast-export/cvs-fast-export-1.52.ebuild [new file with mode: 0644]

index f30d663b4ac7740d32a4e3056217405717b1d5e9..122e99c4ec03a9975e75692cf28b1e48e142d53c 100644 (file)
@@ -1 +1,2 @@
 DIST cvs-fast-export-1.51.tar.gz 459647 BLAKE2B ebaa1aeedee5de2b7d76cdb0d91897bc779b2cff9b6ae9ddc5b3872f36792e0e1c3f152e340d50c25c5bbef3c7be4af5a0cc4d7f2fd5f12c722c45c43510afcc SHA512 3b004ad1a295722b7610444be2ff67097e7099fb17fdd1ebd2d237a30ffc2a31e8a90b5344a9488f3ea3abd4e104bdc0cff2d28dd56321df76ae9bf6f25e90f4
+DIST cvs-fast-export-1.52.tar.gz 468734 BLAKE2B 2f1783df682b4c42aa8f3ecc6b0bdfbc641a08e92e649bb0de25b1b6d99c87aebe34488ba928570cce7dd6427c3f5cdc4cb7bc2abb3b5da7f43b53b958770b72 SHA512 eac6843c392a6e6820da2291dec3309c6ed309b89ee5c0784160292e8f8157b6d6e127508c37c29dffe32477fafe38b94a45e1036927b5deb040589132863def
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.52.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.52.ebuild
new file mode 100644 (file)
index 0000000..976b11d
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship some tests in tarball
+
+src_prepare() {
+       default
+
+       tc-export CC
+       export prefix="${EPREFIX}"/usr
+
+       # respect CC, CFLAGS and LDFLAGS
+       sed \
+               -e 's/cc /$(CC) $(LDFLAGS) /' \
+               -e 's/^CFLAGS += -O/#&/' \
+               -e 's/CFLAGS=/CFLAGS+=/' \
+               -i Makefile || die
+}
+
+src_compile() {
+       # '.adoc.html' rules can't be executed in parallel
+       # as they reuse the same 'docbook-xsl.css' file name.
+       emake -j1 html
+       # Allow full parallelism for the rest
+       emake
+}
+
+src_install() {
+       default
+       dodoc README.adoc
+}