dev-python/pygraphviz: 1.5 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 10 Apr 2019 03:07:32 +0000 (22:07 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 10 Apr 2019 05:07:13 +0000 (00:07 -0500)
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/pygraphviz/Manifest
dev-python/pygraphviz/files/pygraphviz-1.5-docs.patch [new file with mode: 0644]
dev-python/pygraphviz/pygraphviz-1.5.ebuild [new file with mode: 0644]

index 1ecd7b070c71eb7dd4417532212265a6c5a89152..e7eaf2d6dc0c74c5c963092a6fa2cbaa062aac63 100644 (file)
@@ -1,2 +1,3 @@
 DIST pygraphviz-1.2.tar.gz 90913 BLAKE2B 2031b3d1366ce038fc10a1ed632bae9ae67789eae1c45e9e9eb418cf8e5729d47baed96508f52e962aa0138a1fa6231a50bbba2049435f4af959ef467eaa7454 SHA512 e477af635594c3ba1aa6fa499bc5e60df14e76616a1a777f648e2e96d3953dd3d0b3bae4a92275dac2f7466276cf526ecb8b6a63fd3fbad26ee24b67d76ecfa3
 DIST pygraphviz-1.3.1.tar.gz 103336 BLAKE2B 267c85ca4639a2f0ad8c06d36eaa1f2026c6afafe357be23ea4c108b7953aedac2f397bf262a68f336385a5810d77bec9d200bf86da3d101b4d402dcc2d77e1f SHA512 e1957d7daf7ae9e60873cb6f23ac19a3320b4b10579ab24a2307beb558dad11a8e82e1da528799165b761d944efb4860b7296e3218846f7885f715c396a8e3dc
+DIST pygraphviz-1.5.zip 117810 BLAKE2B e9139d6b8e01cacb3135b1ccd2fa8624c041b7a04848f66c7668c5acf55cf66380ab9f05193b1bb240133f0c01a21915e2314807fcde23246c287d22efb9450a SHA512 6d3df6642a7e23ecb6b687761480b80a3ee5886508ef50b81697041425be7d09d623bf46990c5cea3ef36817a28d9e5c2905eb32267296f55524fdedb2199ea2
diff --git a/dev-python/pygraphviz/files/pygraphviz-1.5-docs.patch b/dev-python/pygraphviz/files/pygraphviz-1.5-docs.patch
new file mode 100644 (file)
index 0000000..aed5c90
--- /dev/null
@@ -0,0 +1,29 @@
+ setup.py | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index fc0a96f..98b7f58 100644
+--- a/setup.py
++++ b/setup.py
+@@ -36,13 +36,6 @@ release.write_versionfile()
+ sys.path.pop(0)
+ packages = ["pygraphviz", "pygraphviz.tests"]
+-docdirbase = 'share/doc/pygraphviz-%s' % release.version
+-data = [
+-    (docdirbase, glob("*.txt")),
+-    (os.path.join(docdirbase, 'examples'), glob("examples/*.py")),
+-    (os.path.join(docdirbase, 'examples'), glob("examples/*.dat")),
+-    (os.path.join(docdirbase, 'examples'), glob("examples/*.dat.gz")),
+-]
+ package_data = {'': ['*.txt'], }
+ if __name__ == "__main__":
+@@ -75,7 +68,6 @@ if __name__ == "__main__":
+         download_url=release.download_url,
+         classifiers=release.classifiers,
+         packages=packages,
+-        data_files=data,
+         ext_modules=extension,
+         cmdclass={
+             'install': AddExtensionInstallCommand,
diff --git a/dev-python/pygraphviz/pygraphviz-1.5.ebuild b/dev-python/pygraphviz/pygraphviz-1.5.ebuild
new file mode 100644 (file)
index 0000000..81ce319
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for the Graphviz Agraph data structure"
+HOMEPAGE="http://pygraphviz.github.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="examples test"
+
+# Note: only C API of graphviz is used, PYTHON_USEDEP unnecessary.
+RDEPEND="media-gfx/graphviz"
+DEPEND="${RDEPEND}
+       dev-lang/swig:0
+       test? (
+               dev-python/doctest-ignore-unicode[${PYTHON_USEDEP}]
+               dev-python/nose[${PYTHON_USEDEP}]
+       )
+"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-docs.patch
+)
+
+python_prepare_all() {
+       distutils-r1_python_prepare_all
+       swig -python pygraphviz/graphviz.i || die
+}
+
+python_test() {
+       PYTHONPATH=${PYTHONPATH}:${BUILD_DIR}/lib/pygraphviz \
+               nosetests -c setup.cfg -x -v || die
+}
+
+python_install_all() {
+       use examples && local EXAMPLES=( examples/. )
+
+       distutils-r1_python_install_all
+}