media-libs/aubio: Fix USE flag conflicts
authorAndreas Sturmlechner <asturm@gentoo.org>
Mon, 1 Oct 2018 19:31:48 +0000 (21:31 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Mon, 1 Oct 2018 20:08:19 +0000 (22:08 +0200)
Thanks-to: ak <4nykey@gmail.com>
Closes: https://bugs.gentoo.org/605750
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Package-Manager: Portage-2.3.50, Repoman-2.3.11

media-libs/aubio/aubio-0.4.7.ebuild

index 0592ffa0a50d7b6ee9c59a18e02a3d52d78748d0..a7d7db9a590a451987ec1caa15e126f91dba9010 100644 (file)
@@ -37,7 +37,9 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig
        doc? ( app-doc/doxygen )
 "
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+       ?? ( double-precision libsamplerate )
+"
 
 DOCS=( AUTHORS ChangeLog README.md )
 PYTHON_SRC_DIR="${S}"
@@ -49,16 +51,19 @@ src_prepare() {
 
 src_configure() {
        python_setup
-       waf-utils_src_configure \
-               --enable-complex \
-               --docdir="${EPREFIX}"/usr/share/doc/${PF} \
-               $(use_enable double-precision double) \
-               $(use_enable fftw fftw3f) \
-               $(use_enable fftw fftw3) \
-               $(use_enable ffmpeg avcodec) \
-               $(use_enable jack) \
-               $(use_enable libsamplerate samplerate) \
+       local mywafconfargs=(
+               --enable-complex
+               --docdir="${EPREFIX}"/usr/share/doc/${PF}
+               $(use_enable double-precision double)
+               $(use_enable fftw fftw3)
+               $(use_enable ffmpeg avcodec)
+               $(use_enable jack)
+               $(use_enable libsamplerate samplerate)
                $(use_enable sndfile)
+       )
+       use double-precision || mywafconfargs+=( $(use_enable fftw fftw3f) )
+
+       waf-utils_src_configure "${mywafconfargs[@]}"
 
        if use python ; then
                cd "${PYTHON_SRC_DIR}" || die