dev-python/mando: Remove old
authorMichał Górny <mgorny@gentoo.org>
Fri, 24 Apr 2020 20:04:13 +0000 (22:04 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 24 Apr 2020 20:12:58 +0000 (22:12 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/mando/Manifest
dev-python/mando/mando-0.3.2.ebuild [deleted file]

index 2db64f33799711de8bb1fe9dd28eeae5b6ecbfa7..cadf33026638f52981068c9f31b2200eae959b0e 100644 (file)
@@ -1,2 +1 @@
-DIST mando-0.3.2.tar.gz 22393 BLAKE2B bf6a7df4a6e2e8270d0b8fa278cde7d520bf5c9d490dec748927d8f7c024381094f946e5feb4b5334b0d7255df002aeb1b42b8545b7514194425e37f739d2da9 SHA512 57f5041ad175c4eca4c158d9d917dcb1f9c25978c60aa0e76322d0395b0edbc3fb7b062da7b9af871a97bbd46cfe7f81e634287f813baf15ef134be53150bd11
 DIST mando-0.6.4.tar.gz 36560 BLAKE2B 9878746485d4b896c3e32512b77ac02739940a1398eee12056fd6719cc3c99f8c526c8e573d2556b6a9d0d8d26e20fb45c97119e626b1d44f0a5b5f4655adba1 SHA512 457fa0db4e8e5dbfac6146d254181213814ef1975c919b4573007face27749ec3a50eda850558ebdc0fdff94a5e9819fd825b10cb3023078b2b426c2825fdbf0
diff --git a/dev-python/mando/mando-0.3.2.ebuild b/dev-python/mando/mando-0.3.2.ebuild
deleted file mode 100644 (file)
index 5e16ff3..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Create Python CLI apps with little to no effort at all!"
-HOMEPAGE="https://mando.readthedocs.org/"
-SRC_URI="https://github.com/rubik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( dev-python/paramunittest[${PYTHON_USEDEP}] )
-"
-RDEPEND=""
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       "${PYTHON}" mando/tests/run.py || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       if use examples; then
-               dodoc -r examples
-               docompress -x /usr/share/doc/${PF}/examples
-       fi
-
-       distutils-r1_python_install_all
-}