dev-python/pytest-salt-2020.1.27: Version bump
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 29 Apr 2020 00:11:41 +0000 (17:11 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 29 Apr 2020 00:22:19 +0000 (17:22 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/pytest-salt/Manifest
dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild [new file with mode: 0644]

index 5e84b8c39769b4728f37382f5441566c5ab9da70..040d7f4ef99985dfdcbc9e8816a4029a7bb9a9ab 100644 (file)
@@ -1 +1,2 @@
 DIST pytest-salt-2019.2.1.post1.tar.gz 63824 BLAKE2B 684e1dee6df8f7459bfa1747ea017973d72bc69b87d22c65509ecada47469a94ce410034004a5df1396d5ed05557ddec90e34cb18792235babb5e0cf6d72d776 SHA512 7b9939c3bd1cbcb6d6d0b086c39e02deadd8b3c6fcc359924af7fa5afc2e443b927269b82aa5575413e4e6bbc052f4035fb17ab68dac59ea309320c0a647d36d
+DIST pytest-salt-2020.1.27.tar.gz 64141 BLAKE2B 2b9261af2de28f8dce1abcd71b586594075916c8a5dbb27a24f15b9d95a575624be118d1c742f02020d3b968ffa4654cf6cd0dabefffe6876b87a4d1d58c3d60 SHA512 b0632e21f1ea5c3b57eb681cd8b270721cafd270321b708fca65427fc89817ed9e9a4216a520f35988c6866b1ed76ed84838009da9052a11cf8782d4dcf118ba
diff --git a/dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild b/dev-python/pytest-salt/pytest-salt-2020.1.27.ebuild
new file mode 100644 (file)
index 0000000..30088fd
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+MY_PV="${PV/_p/.post}"
+DESCRIPTION="PyTest Salt Plugin"
+HOMEPAGE="https://github.com/saltstack/pytest-salt"
+SRC_URI="https://github.com/saltstack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+       >=dev-python/pytest-2.8.1[${PYTHON_USEDEP}]
+       >=dev-python/psutil-4.2.0[${PYTHON_USEDEP}]
+       dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+       dev-python/pytest-tempdir[${PYTHON_USEDEP}]
+"
+#BDEPEND="
+#      test? ( app-admin/salt[${PYTHON_USEDEP}] )
+#"
+
+# tests need network access
+RESTRICT="test"
+
+distutils_enable_tests pytest
+
+python_test() {
+       distutils_install_for_testing
+       pytest -vv || die "Tests failed with ${EPYTHON}"
+}