dev-python/oauthlib: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:25:32 +0000 (13:25 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:25:32 +0000 (13:25 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/oauthlib/Manifest
dev-python/oauthlib/oauthlib-3.0.1.ebuild [deleted file]

index d41c4005a66f8cae13f1ad15e10409b75176c333..62d9b15d1d24f8a8274c4053b8c75f243c80b84e 100644 (file)
@@ -1,2 +1 @@
-DIST oauthlib-3.0.1.tar.gz 149303 BLAKE2B daf826a3959f56f70b7f52ac1fc98d8ec73161316235cf7f0dce17469999383faa1b11c50c9645748b39938ae1d24dc3dea3908b68daf8c838f99df763bc361d SHA512 88ee266f764488090b849c036d2475c31dab0d8b18bd6afd0450da6aa0982ba17cdada7d0c25791d5efcf89601f69ae40cd21c584540448c209f90d36e0e98f8
 DIST oauthlib-3.1.0.tar.gz 155362 BLAKE2B 83e9331589305c85acc755f9c4dab8558a19aa247aff5be0fe6c51d047fb9e96b64f17d07a3e33378f6ebc73a283e0162bab56e110aca581f73b628544042600 SHA512 c295de232e0215532c501d8f0803bd501a15fe89a746179ba4facca878e4927c8c05f07825f483c4a846922fb49d6d89f559a8b49bb72b19903f902d772b790e
diff --git a/dev-python/oauthlib/oauthlib-3.0.1.ebuild b/dev-python/oauthlib/oauthlib-3.0.1.ebuild
deleted file mode 100644 (file)
index 5b0c7b2..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Spec-compliant and thorough implementation of the OAuth request-signing logic"
-HOMEPAGE="https://github.com/idan/oauthlib https://pypi.org/project/oauthlib/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# optional extras hard set as RDEPs. See setup.py
-RDEPEND="
-       >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
-       dev-python/blinker[${PYTHON_USEDEP}]
-       dev-python/cryptography[${PYTHON_USEDEP}]
-       "
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( ${RDEPEND}
-               dev-python/nose[${PYTHON_USEDEP}] )
-       "
-
-python_test() {
-       nosetests -v || die "tests failed under ${EPYTHON}"
-}