dev-libs/libclsync: remove dependency on app-admin/clsync
authorAndrew Savchenko <bircoph@gentoo.org>
Fri, 30 Sep 2016 14:00:00 +0000 (17:00 +0300)
committerAndrew Savchenko <bircoph@gentoo.org>
Fri, 30 Sep 2016 14:02:02 +0000 (17:02 +0300)
It is rare, but still valid use case to use libclsync when clsync
is not installed on the host (or lacks socket control support):
socket can be passed from another host/container via shared file
system, or can be converted to udp using socat.

Package-Manager: portage-2.3.1
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
dev-libs/libclsync/libclsync-0.4.2.ebuild

index 094b8d99d3dbb6eeabdb79d5eae5f6e22dad4fd4..2184de44d3946c962df2f3cccabc2f561f5ea144 100644 (file)
@@ -24,9 +24,7 @@ REQUIRED_USE="
 "
 
 DEPEND="virtual/pkgconfig"
-RDEPEND="
-       =app-admin/clsync-0.4*[control-socket]
-       =app-doc/clsync-docs-0.4*"
+RDEPEND="=app-doc/clsync-docs-0.4*"
 
 src_prepare() {
        eapply_user
@@ -70,3 +68,8 @@ src_install() {
        # docs go into clsync-docs
        rm -rf "${ED}/usr/share/doc" || die
 }
+
+pkg_postinst() {
+       einfo "clsync instances you are going to use _must_ be compiled"
+       einfo "with control-socket support"
+}