projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9ad2733
)
dev-python/polygon: Enable py3.{7,8}
author
Michał Górny
<mgorny@gentoo.org>
Sat, 25 Apr 2020 09:02:39 +0000
(11:02 +0200)
committer
Michał Górny
<mgorny@gentoo.org>
Sat, 25 Apr 2020 09:07:16 +0000
(11:07 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/polygon/polygon-3.0.7.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/polygon/polygon-3.0.7.ebuild
b/dev-python/polygon/polygon-3.0.7.ebuild
index e3e7bcdb41355b200e585e8cf0c4601981196929..e9821f63b466d1ae7d031cc6c87e7938ff403d32 100644
(file)
--- a/
dev-python/polygon/polygon-3.0.7.ebuild
+++ b/
dev-python/polygon/polygon-3.0.7.ebuild
@@
-2,7
+2,9
@@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PYTHON_COMPAT=( python3_6 )
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@
-30,7
+32,7
@@
python_prepare_all() {
}
python_test() {
-
${PYTHON} test/Test.py
|| die "Tests failed under ${EPYTHON}"
+
"${EPYTHON}" test/Test.py -v
|| die "Tests failed under ${EPYTHON}"
}
python_install_all() {