x11-apps/scripts: bump EAPI 3 -> 5
authorHarri Nieminen <moikkis@gmail.com>
Sat, 11 Mar 2017 15:51:57 +0000 (17:51 +0200)
committerDavid Seifert <soap@gentoo.org>
Thu, 16 Mar 2017 19:12:18 +0000 (20:12 +0100)
No changes in files. Checked with sha512sum

Package-Manager: Portage-2.3.4, Repoman-2.3.2
Closes: https://github.com/gentoo/gentoo/pull/4186

x11-apps/scripts/scripts-1.0.1-r1.ebuild

index bee20312524c6927911773d25c196559600f51ea..064806f4a2fe0f94e0574ec1d01f6e867ce756b6 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=3
+EAPI=5
 
 XORG_STATIC="no"
 inherit xorg-2
@@ -9,6 +9,7 @@ inherit xorg-2
 DESCRIPTION="start an X program on a remote machine"
 KEYWORDS="amd64 arm ~arm64 ~mips ppc ppc64 s390 sh ~sparc x86 ~amd64-linux ~x86-linux"
 IUSE=""
+
 RDEPEND="x11-libs/libX11"
 DEPEND="${RDEPEND}"
 
@@ -16,5 +17,5 @@ src_install() {
        xorg-2_src_install
 
        # Requires ksh, assumes hostname(1) is in /usr/bin
-       rm "${ED}"/usr/bin/xauth_switch_to_sun-des-1
+       rm "${ED%/}"/usr/bin/xauth_switch_to_sun-des-1 || die
 }