dev-perl/Inline-Python: Add support up to python3_8
authorKent Fredric <kentnl@gentoo.org>
Thu, 21 May 2020 09:35:04 +0000 (21:35 +1200)
committerKent Fredric <kentnl@gentoo.org>
Thu, 21 May 2020 09:53:03 +0000 (21:53 +1200)
- EAPI7 conversion
- Add python3_7 and python3_8 support

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Inline-Python/Inline-Python-0.560.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Inline-Python/Inline-Python-0.560.0-r1.ebuild b/dev-perl/Inline-Python/Inline-Python-0.560.0-r1.ebuild
new file mode 100644 (file)
index 0000000..08eec20
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+# Feel free to add more targets after testing.
+
+DIST_AUTHOR=NINE
+DIST_VERSION=0.56
+inherit python-single-r1 perl-module
+
+DESCRIPTION="Easy implementation of Python extensions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       virtual/perl-Data-Dumper
+       >=virtual/perl-Digest-MD5-2.500.0
+       >=dev-perl/Inline-0.460.0
+       ${PYTHON_DEPS}
+"
+DEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               >=dev-perl/Proc-ProcessTable-0.530.0
+               virtual/perl-Test-Simple
+               dev-perl/Test-Deep
+               dev-perl/Test-Number-Delta
+               virtual/perl-Test
+       )
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.460.0-insanepython.patch" )