sci-biology/rnaview: Modernise to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 15:23:28 +0000 (16:23 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 25 Feb 2017 15:24:04 +0000 (16:24 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

sci-biology/rnaview/files/rnaview-20040713-implicit.patch
sci-biology/rnaview/rnaview-20040713-r4.ebuild [new file with mode: 0644]

index 009f6e79ae864fd009f932423519711265568001..90ea72ab6f8c83c3e3d53543f9f2999627e60d0f 100644 (file)
@@ -1,7 +1,7 @@
 Fix implicit function declaration
 
---- src/xml2ps.c
-+++ src/xml2ps.c
+--- a/src/xml2ps.c
++++ b/src/xml2ps.c
 @@ -36,7 +36,7 @@
  void read_sugar_syn(char *inpfile, long **sugar_syn);
  void get_sugar_syn(FILE *inp, char *value_ch);
diff --git a/sci-biology/rnaview/rnaview-20040713-r4.ebuild b/sci-biology/rnaview/rnaview-20040713-r4.ebuild
new file mode 100644 (file)
index 0000000..f12c6ce
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Generates 2D displays of RNA/DNA secondary structures with tertiary interactions"
+HOMEPAGE="http://ndbserver.rutgers.edu/services/download/index.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=(
+       "${FILESDIR}"/${P}-makefile.patch
+       "${FILESDIR}"/${P}-implicit.patch
+)
+
+src_prepare() {
+       default
+       tc-export CC
+}
+
+src_install() {
+       default
+
+       cat > 22rnaview <<- EOF || die
+               RNAVIEW="${EPREFIX}/usr/share/${PN}"
+       EOF
+       doenvd 22rnaview
+}