dev-libs/libxml2: bump to 2.9.6
authorMike Gilbert <floppym@gentoo.org>
Thu, 19 Oct 2017 15:05:29 +0000 (11:05 -0400)
committerMike Gilbert <floppym@gentoo.org>
Thu, 19 Oct 2017 15:05:29 +0000 (11:05 -0400)
Closes: https://bugs.gentoo.org/634496
Package-Manager: Portage-2.3.11_p4, Repoman-2.3.3_p62

dev-libs/libxml2/Manifest
dev-libs/libxml2/libxml2-2.9.6.ebuild [new file with mode: 0644]

index 1ae6e49b2f868279376a4f8f5eea0e774d79df8c..e95b736e00070a523869eaa4e637743500ab6164 100644 (file)
@@ -1,5 +1,6 @@
 DIST libxml2-2.9.4.tar.gz 5374830 SHA256 ffb911191e509b966deb55de705387f14156e1a56b21824357cdf0053233633c SHA512 f5174ab1a3a0ec0037a47f47aa47def36674e02bfb42b57f609563f84c6247c585dbbb133c056953a5adb968d328f18cbc102eb0d00d48eb7c95478389e5daf9 WHIRLPOOL 268d3364a3d293810dff060b3ab92042c5550e50dbe9038c4d5b54ea6a22ed77f9572575517ae3bacfe518d634047eb9d5345e903b125e56a3d32ad1ba96dabf
 DIST libxml2-2.9.5.tar.gz 5466888 SHA256 4031c1ecee9ce7ba4f313e91ef6284164885cdb69937a123f6a83bb6a72dcd38 SHA512 197dbd1722e5f90eea43837323352f48d215e198aa6b95685645ef7511e2beba8aadc0dd67e099c945120c5dbe7f8c9da5f376b22f447059e9ffa941c1bfd175 WHIRLPOOL 14cfeaa1c18af4e64131505010484b2e64d83d617984c6321b77c4263901b16b24c945eb9af17763fe63048c3910111fdc498fe9183c04ecea9182ea8f9214fa
+DIST libxml2-2.9.6.tar.gz 5469624 SHA256 8b9038cca7240e881d462ea391882092dfdc6d4f483f72683e817be08df5ebbc SHA512 5ef80f895374bd5dd3bcd5f00c715795f026bf45d998f8f762c0cdb739b8755e01de40cf853d98a3826eacef95c4adebe4777db11020e8d98d0bda921f55a0ed WHIRLPOOL 1fa2b10f8715f3718863957e6a5173400b42c6587c4602f52c0ae9103fafd7a515c28158c9bc928c532139cd73274f070015c64677434a0a6fa83f0a9e8425ff
 DIST xmlts20080827.tar.gz 638940 SHA256 96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7 SHA512 7325d0977c4427fc4944b291ccf896a665f654cc24399e5565c12a849c2bc3aef4fa3ee42a09ac115abcb6570c51a8fbd052c38d64d164279ecdecad5a4e884d WHIRLPOOL 50835380c3ea208df0bf9ce032ed2df69c4c6cb5a53ffdd39a08fb4f1d166f311b2ef2fe0d9911ae1ebff92aeb42f6ea55e727dfe0b7a3b95e6c7240315b3eda
 DIST xsts-2002-01-16.tar.gz 6894439 SHA256 55e5c08db29946a91ea8e70e8f2418d3fd30d8b6777941dfba7f54726ffd9914 SHA512 43300af6d39c1e2221b0ed7318fe14c7464eeb6eb030ed1e22eb29b4ab17f014e2a4c8887c3a46ae5d243e3072da27f00f4e285498ae6f1288177d38d1108288 WHIRLPOOL 84dd51959460a4f8aa582d57ad39229c546ca7fe155012c57c368b59f5d31400d8b940a343a7320058330ca611303139cacdffed514783f96406ac5366026b11
 DIST xsts-2004-01-14.tar.gz 2761085 SHA256 09bdf9f81f381ebf9bc158a9472e498e896f7a02eb7461146e9abe1b9493ca17 SHA512 32854388d7e720ad67156baf50bf2bae7bd878ca3e35fd7e44e57cad3f434f69d56bbbedd61509f8a1faf01c9eae74a078df8fe130780b182c05c05cb1c39ebe WHIRLPOOL c46a3bf7d6dd771757f4304995cc177cf51c6cdd0e9778851fc13d3809c7b984690b4f273b3e075abe018110968eb7fc78f5b83170d3e18bacf00a4ed64b213d
diff --git a/dev-libs/libxml2/libxml2-2.9.6.ebuild b/dev-libs/libxml2/libxml2-2.9.6.ebuild
new file mode 100644 (file)
index 0000000..dc7fa4d
--- /dev/null
@@ -0,0 +1,208 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="xml"
+
+inherit libtool flag-o-matic ltprune python-r1 autotools prefix multilib-minimal
+
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="debug examples icu ipv6 lzma python readline static-libs test"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+XSTS_HOME="http://www.w3.org/XML/2004/xml-schema-test-suite"
+XSTS_NAME_1="xmlschema2002-01-16"
+XSTS_NAME_2="xmlschema2004-01-14"
+XSTS_TARBALL_1="xsts-2002-01-16.tar.gz"
+XSTS_TARBALL_2="xsts-2004-01-14.tar.gz"
+XMLCONF_TARBALL="xmlts20080827.tar.gz"
+
+SRC_URI="ftp://xmlsoft.org/${PN}/${PN}-${PV/_rc/-rc}.tar.gz
+       test? (
+               ${XSTS_HOME}/${XSTS_NAME_1}/${XSTS_TARBALL_1}
+               ${XSTS_HOME}/${XSTS_NAME_2}/${XSTS_TARBALL_2}
+               http://www.w3.org/XML/Test/${XMLCONF_TARBALL} )"
+
+RDEPEND="
+       >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}]
+       icu? ( >=dev-libs/icu-51.2-r1:=[${MULTILIB_USEDEP}] )
+       lzma? ( >=app-arch/xz-utils-5.0.5-r1:=[${MULTILIB_USEDEP}] )
+       python? ( ${PYTHON_DEPS} )
+       readline? ( sys-libs/readline:= )
+"
+DEPEND="${RDEPEND}
+       dev-util/gtk-doc-am
+       virtual/pkgconfig
+       hppa? ( >=sys-devel/binutils-2.15.92.0.2 )
+"
+
+S="${WORKDIR}/${PN}-${PV%_rc*}"
+
+MULTILIB_CHOST_TOOLS=(
+       /usr/bin/xml2-config
+)
+
+src_unpack() {
+       # ${A} isn't used to avoid unpacking of test tarballs into $WORKDIR,
+       # as they are needed as tarballs in ${S}/xstc instead and not unpacked
+       unpack ${P/_rc/-rc}.tar.gz
+       cd "${S}" || die
+
+       if use test; then
+               cp "${DISTDIR}/${XSTS_TARBALL_1}" \
+                       "${DISTDIR}/${XSTS_TARBALL_2}" \
+                       "${S}"/xstc/ \
+                       || die "Failed to install test tarballs"
+               unpack ${XMLCONF_TARBALL}
+       fi
+}
+
+src_prepare() {
+       default
+
+       DOCS=( AUTHORS ChangeLog NEWS README* TODO* )
+
+       # Patches needed for prefix support
+       eapply "${FILESDIR}"/${PN}-2.7.1-catalog_path.patch
+
+       eprefixify catalog.c xmlcatalog.c runtest.c xmllint.c
+
+       # Fix build for Windows platform
+       # https://bugzilla.gnome.org/show_bug.cgi?id=760456
+       eapply "${FILESDIR}"/${PN}-2.8.0_rc1-winnt.patch
+
+       # Fix python detection, bug #567066
+       # https://bugzilla.gnome.org/show_bug.cgi?id=760458
+       eapply "${FILESDIR}"/${PN}-2.9.2-python-ABIFLAG.patch
+
+       # Avoid final linking arguments for python modules
+       if [[ ${CHOST} == *-darwin* ]] ; then
+               sed -i -e '/PYTHON_LIBS/s/ldflags/libs/' configure.ac || die
+       fi
+
+       # Please do not remove, as else we get references to PORTAGE_TMPDIR
+       # in /usr/lib/python?.?/site-packages/libxml2mod.la among things.
+       # We now need to run eautoreconf at the end to prevent maintainer mode.
+#      elibtoolize
+#      epunt_cxx # if we don't eautoreconf
+
+       eautoreconf
+}
+
+multilib_src_configure() {
+       # filter seemingly problematic CFLAGS (#26320)
+       filter-flags -fprefetch-loop-arrays -funroll-loops
+
+       # USE zlib support breaks gnome2
+       # (libgnomeprint for instance fails to compile with
+       # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+
+       # The meaning of the 'debug' USE flag does not apply to the --with-debug
+       # switch (enabling the libxml2 debug module). See bug #100898.
+
+       # --with-mem-debug causes unusual segmentation faults (bug #105120).
+
+       libxml2_configure() {
+               ECONF_SOURCE="${S}" econf \
+                       --with-html-subdir=${PF}/html \
+                       $(use_with debug run-debug) \
+                       $(use_with icu) \
+                       $(use_with lzma) \
+                       $(use_enable ipv6) \
+                       $(use_enable static-libs static) \
+                       $(multilib_native_use_with readline) \
+                       $(multilib_native_use_with readline history) \
+                       "$@"
+       }
+
+       libxml2_py_configure() {
+               mkdir -p "${BUILD_DIR}" || die # ensure python build dirs exist
+               run_in_build_dir libxml2_configure "--with-python=${ROOT%/}${PYTHON}" # odd build system, also see bug #582130
+       }
+
+       libxml2_configure --without-python # build python bindings separately
+
+       if multilib_is_native_abi && use python; then
+               python_foreach_impl libxml2_py_configure
+       fi
+}
+
+multilib_src_compile() {
+       default
+       if multilib_is_native_abi && use python; then
+               local native_builddir=${BUILD_DIR}
+               python_foreach_impl libxml2_py_emake top_builddir="${native_builddir}" all
+       fi
+}
+
+multilib_src_test() {
+       emake check
+       multilib_is_native_abi && use python && python_foreach_impl libxml2_py_emake test
+}
+
+multilib_src_install() {
+       emake DESTDIR="${D}" \
+               EXAMPLES_DIR="${EPREFIX}"/usr/share/doc/${PF}/examples install
+
+       if multilib_is_native_abi && use python; then
+               python_foreach_impl libxml2_py_emake \
+                       DESTDIR="${D}" \
+                       docsdir="${EPREFIX}"/usr/share/doc/${PF}/python \
+                       exampledir="${EPREFIX}"/usr/share/doc/${PF}/python/examples \
+                       install
+               python_foreach_impl python_optimize
+       fi
+}
+
+multilib_src_install_all() {
+       # on windows, xmllint is installed by interix libxml2 in parent prefix.
+       # this is the version to use. the native winnt version does not support
+       # symlinks, which makes repoman fail if the portage tree is linked in
+       # from another location (which is my default). -- mduft
+       if [[ ${CHOST} == *-winnt* ]]; then
+               rm -rf "${ED}"/usr/bin/xmllint
+               rm -rf "${ED}"/usr/bin/xmlcatalog
+       fi
+
+       rm -rf "${ED}"/usr/share/doc/${P}
+       einstalldocs
+
+       if ! use examples; then
+               rm -rf "${ED}"/usr/share/doc/${PF}/examples
+               rm -rf "${ED}"/usr/share/doc/${PF}/python/examples
+       fi
+
+       prune_libtool_files --modules
+}
+
+pkg_postinst() {
+       # We don't want to do the xmlcatalog during stage1, as xmlcatalog will not
+       # be in / and stage1 builds to ROOT=/tmp/stage1root. This fixes bug #208887.
+       if [[ "${ROOT}" != "/" ]]; then
+               elog "Skipping XML catalog creation for stage building (bug #208887)."
+       else
+               # need an XML catalog, so no-one writes to a non-existent one
+               CATALOG="${EROOT}etc/xml/catalog"
+
+               # we dont want to clobber an existing catalog though,
+               # only ensure that one is there
+               # <obz@gentoo.org>
+               if [[ ! -e ${CATALOG} ]]; then
+                       [[ -d "${EROOT}etc/xml" ]] || mkdir -p "${EROOT}etc/xml"
+                       "${EPREFIX}"/usr/bin/xmlcatalog --create > "${CATALOG}"
+                       einfo "Created XML catalog in ${CATALOG}"
+               fi
+       fi
+}
+
+libxml2_py_emake() {
+       pushd "${BUILD_DIR}/python" > /dev/null || die
+       emake "$@"
+       popd > /dev/null
+}