www-client/opera-beta: Version 62.0.3331.14
authorJeroen Roovers <jer@gentoo.org>
Wed, 19 Jun 2019 16:09:39 +0000 (18:09 +0200)
committerJeroen Roovers <jer@gentoo.org>
Thu, 20 Jun 2019 07:10:03 +0000 (09:10 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
www-client/opera-beta/Manifest
www-client/opera-beta/opera-beta-62.0.3331.14.ebuild [new file with mode: 0644]

index 62f83c4fb4e81a2b701b3801a84ecf99ee1eda88..1288c6cace4ec1d51c95c908e6edcddfdf3f8bbd 100644 (file)
@@ -1,2 +1,3 @@
 DIST opera-beta_62.0.3331.10_amd64.deb 67188850 BLAKE2B 39a9ef837022bd631592f5cc0c116a01d469fed69f36ba2e4f17c39077d915accc2bcbae2d3e5984d32be02d1ab4d0ba16e753ce9b63627750ddd9a94cfd825b SHA512 3b0bbf0e2e18237bf0da31c831b5314468d8c73e9a63a009f3d85132cbdf0d0786e8feb257d735f7cb293f168e83afcd9583eb5e53c883f8a2ca90cc6c8ae1b0
+DIST opera-beta_62.0.3331.14_amd64.deb 67233250 BLAKE2B 0d5c0f32ad3830617e9c26dc46301661d05107447baecfe096c75a5ea508335daa2e6d1aae239df90dc1ffdc76a3b32048c6c0b46e6d9eb016ff9c36623e1f8b SHA512 4aa5ed07e489cbbedb31204d757353d186918e926ebec6c1111cb6c9bdd04bade8f21e6023db8007d695da7a93a48479bf1ddd04c2aa9c27b92b10e9a102d233
 DIST opera-beta_62.0.3331.5_amd64.deb 66671778 BLAKE2B 7fde67b73c0af74aeeab4318ea326369c24a0d9ec72b755ff978d7d952b7c24b5bb1a119746282adfde1aba456c48ae8785a0c6e7b8a4f46fa37effdad1d27d9 SHA512 4c78b25910602b05ce4aa2b3bab5d962fc583a38fa409dfa231320f1be9fe5abd4c4d0265a5c3686f4888f5808b12a5ff09b7a2381e6a786db24caa32e15844c
diff --git a/www-client/opera-beta/opera-beta-62.0.3331.14.ebuild b/www-client/opera-beta/opera-beta-62.0.3331.14.ebuild
new file mode 100644 (file)
index 0000000..59a8587
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CHROMIUM_LANGS="
+       be bg bn ca cs da de el en-GB es es-419 fi fil fr fr-CA hi hr hu id it
+       ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+       zh-CN zh-TW
+"
+inherit chromium-2 multilib unpacker xdg-utils
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+LICENSE="OPERA-2014"
+SLOT="0"
+SRC_URI_BASE="
+       https://download1.operacdn.com/pub/
+       https://download2.operacdn.com/pub/
+       https://download3.operacdn.com/pub/
+       https://download4.operacdn.com/pub/
+"
+SRC_URI="amd64? ("
+for uri in ${SRC_URI_BASE}; do
+SRC_URI+="
+       "${uri}${PN}/${PV}/linux/${PN}_${PV}_amd64.deb"
+"
+done
+SRC_URI+=")"
+KEYWORDS="~amd64"
+
+RDEPEND="
+       dev-libs/expat
+       dev-libs/glib:2
+       dev-libs/nspr
+       dev-libs/nss
+       gnome-base/gconf:2
+       media-libs/alsa-lib
+       media-libs/fontconfig
+       media-libs/freetype
+       net-misc/curl
+       net-print/cups
+       sys-apps/dbus
+       x11-libs/cairo
+       x11-libs/gdk-pixbuf
+       x11-libs/gtk+:3
+       x11-libs/libX11
+       x11-libs/libXScrnSaver
+       x11-libs/libXcomposite
+       x11-libs/libXcursor
+       x11-libs/libXdamage
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXi
+       x11-libs/libXrandr
+       x11-libs/libXrender
+       x11-libs/libXtst
+       x11-libs/libnotify
+       x11-libs/pango[X]
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+
+pkg_setup() {
+       OPERA_HOME="usr/$(get_libdir)/${PN}"
+}
+
+src_unpack() {
+       unpack_deb ${A}
+}
+
+src_prepare() {
+       default
+
+       case ${ARCH} in
+               amd64)
+                       mv usr/lib/x86_64-linux-gnu usr/$(get_libdir) || die
+                       rm -r usr/lib || die
+                       ;;
+               x86)
+                       mv usr/lib/i386-linux-gnu/${PN} usr/$(get_libdir)/ || die
+                       ;;
+       esac
+
+       mv usr/share/doc/${PN} usr/share/doc/${PF} || die
+       gunzip usr/share/doc/${PF}/changelog.gz || die
+
+       rm usr/bin/${PN} || die
+
+       pushd "${OPERA_HOME}/localization" > /dev/null || die
+       chromium_remove_language_paks
+       popd > /dev/null || die
+
+       sed -i \
+               -e 's|^TargetEnvironment|X-&|g' \
+               usr/share/applications/${PN}.desktop || die
+}
+
+src_install() {
+       mv * "${D}" || die
+       dosym ../$(get_libdir)/${PN}/${PN} /usr/bin/${PN}
+       fperms 4711 /usr/$(get_libdir)/${PN}/opera_sandbox
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}