use games_get_libdir
authorTristan Heaven <tristan@gentoo.org>
Thu, 5 Apr 2007 01:46:12 +0000 (01:46 +0000)
committerTristan Heaven <tristan@gentoo.org>
Thu, 5 Apr 2007 01:46:12 +0000 (01:46 +0000)
Package-Manager: portage-2.1.2.3

games-rpg/dragonhunt/Manifest
games-rpg/dragonhunt/dragonhunt-3.55.ebuild

index e5141d37fbbcdc5a921a7ae81ba2218dbcb67272..c0653f43818e36fdbdba204b426014ec28e55155 100644 (file)
@@ -2,10 +2,10 @@
 Hash: SHA1
 
 DIST Dragon_Hunt-3.55.tar.gz 2159851 RMD160 963dc739d4e464a323acee3f7325713ddb4cb12d SHA1 68d7dbbb0690c23d0c57e8bf03919ecaa70fa6a5 SHA256 d7d73b3ab7aa1c3e91b0221d3759e7da7d07f7569f3d201a00d54624259c84d0
-EBUILD dragonhunt-3.55.ebuild 2369 RMD160 f4d81610330d783c86e7d5313e628f24495adec5 SHA1 368169966be50b18f09765706f3468350e020e49 SHA256 9baa82745656fc20e364230f06759843fe7b0fd1fd3eef2c2e4a455108a2f48b
-MD5 6f3a434f1610ba35527213f46c0c3440 dragonhunt-3.55.ebuild 2369
-RMD160 f4d81610330d783c86e7d5313e628f24495adec5 dragonhunt-3.55.ebuild 2369
-SHA256 9baa82745656fc20e364230f06759843fe7b0fd1fd3eef2c2e4a455108a2f48b dragonhunt-3.55.ebuild 2369
+EBUILD dragonhunt-3.55.ebuild 2167 RMD160 987b2a6b04ecaeb8b36ee47c120c10d401cbd762 SHA1 b8d8165884ba85a50fab49df8920efcbdc1a02d1 SHA256 afe7728f3cc677de39b577c096d91d223bda414386978fefa09078be6f5ec0cd
+MD5 1662bbfe2515977bc32f5c03ca3b8ac8 dragonhunt-3.55.ebuild 2167
+RMD160 987b2a6b04ecaeb8b36ee47c120c10d401cbd762 dragonhunt-3.55.ebuild 2167
+SHA256 afe7728f3cc677de39b577c096d91d223bda414386978fefa09078be6f5ec0cd dragonhunt-3.55.ebuild 2167
 MISC ChangeLog 350 RMD160 4568262cb7ea139a6e8c8fdff817fe6653c7dfbf SHA1 98e5707e68602076e168539d4a438e248fa524c3 SHA256 584125950e6e2cffd135f3138b8b6fc639a21f1958b783ed7a226d46e191da78
 MD5 08890df05c3df59e46ddf162b19b9ea5 ChangeLog 350
 RMD160 4568262cb7ea139a6e8c8fdff817fe6653c7dfbf ChangeLog 350
@@ -18,9 +18,9 @@ MD5 12d9cc6763821d4bc3bf9cc49564a238 files/digest-dragonhunt-3.55 253
 RMD160 c0b9d35491bfa8f5494695cd6e4d10d1fa0b4f11 files/digest-dragonhunt-3.55 253
 SHA256 1fc6a6e7b30dc5d46d35d43150668926f971dbe2c57add3e26480ed7591b56e1 files/digest-dragonhunt-3.55 253
 -----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.5 (GNU/Linux)
+Version: GnuPG v2.0.3 (GNU/Linux)
 
-iD8DBQFFT6pBbfN2jvlVAhwRAvyxAKCGGZkkUL6IOld5oviMyF/xVCVZCwCgqRmj
-YSH4ikoxPY290cpMRAD8F+E=
-=aggs
+iD8DBQFGFFTqdz7hIScOURERAgohAKD5tf+usSeIH/l3OEr+MGCNdW5PEQCeO9h0
+EAVA+oGfRvV7qeX/a/nWSIA=
+=dDUd
 -----END PGP SIGNATURE-----
index 74125cad13ac8f56e4e8ddeef5c7f9820f41ebfc..e06ca26219b319744e4adc0b0ded6da49020511a 100644 (file)
@@ -1,33 +1,30 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/dragonhunt/dragonhunt-3.55.ebuild,v 1.1 2006/11/06 21:33:42 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/dragonhunt/dragonhunt-3.55.ebuild,v 1.2 2007/04/05 01:46:12 nyhm Exp $
 
 inherit games
 
-MY_PN="Dragon_Hunt"
-
+MY_P="Dragon_Hunt-${PV}"
 DESCRIPTION="A simple graphical RPG."
 HOMEPAGE="http://emhsoft.com/dh.html"
-SRC_URI="http://emhsoft.com/dh/${MY_PN}-${PV}.tar.gz"
+SRC_URI="http://emhsoft.com/dh/${MY_P}.tar.gz"
+
 LICENSE="GPL-2 CCPL-ShareAlike-1.0"
 SLOT="0"
-
 KEYWORDS="~amd64 ~x86"
 IUSE=""
 
 RDEPEND="dev-lang/python
        dev-python/pygame"
 
-S="${WORKDIR}/${MY_PN}-${PV}"
-MODULE_DIR="${GAMES_DATADIR}/${PN}/"
-LIB_DIR="${GAMES_LIBDIR}/${PN}"
+S=${WORKDIR}/${MY_P}
 
 src_unpack() {
        unpack ${A}
        cd ${S}
 
        # Where to look for modules to load.
-       sed -i -e "s:\.\./modules/:${MODULE_DIR}:" \
+       sed -i -e "s:\.\./modules/:${GAMES_DATADIR}/${PN}/:" \
                code/g.py \
                code/map_editor.py \
                code/rpg.py \
@@ -51,29 +48,20 @@ src_unpack() {
                -e "s:g.mod_dir.*\"map\.txt\":environ[\"HOME\"]\ +\ \"/dh_map.txt\":" \
                code/map_editor.py \
                || die "Could not change map location."
-
-       # Make the launch scripts look in the right place for the code.
-       sed -i \
-               -e '/^tempname/d' \
-               -e "s:^cd.*:cd ${LIB_DIR}:" \
-               Dragon_Hunt_Linux Map_Editor \
-               || die "Could not change launch location."
 }
 
 src_install() {
-       insinto ${MODULE_DIR}
-       doins -r modules/*
+       insinto "${GAMES_DATADIR}"/${PN}
+       doins -r modules/* || die "doins modules failed"
 
-       insinto ${GAMES_SYSCONFDIR}/${PN}
-       doins settings.txt
+       insinto "${GAMES_SYSCONFDIR}"/${PN}
+       doins settings.txt || die "doins settings.txt failed"
 
-       # Install the code for running the game, the compiled python isn't included
-       # as I cannot safely change the directory paths in it.
-       insinto ${LIB_DIR}
-       doins code/*.py
+       insinto "$(games_get_libdir)"/${PN}
+       doins code/*.py || die "doins code failed"
 
-       newgamesbin Dragon_Hunt_Linux ${PN}
-       newgamesbin Map_Editor ${PN}-mapeditor
+       games_make_wrapper ${PN} "python ./rpg.py" "$(games_get_libdir)"/${PN}
+       games_make_wrapper ${PN}-mapeditor "python ./map_editor.py" "$(games_get_libdir)"/${PN}
 
        dodoc README.txt docs/{Changelog,Items.txt,example_map.txt,tiles.txt}
        dohtml docs/*.html
@@ -83,8 +71,8 @@ src_install() {
 pkg_postinst() {
        games_pkg_postinst
        echo
-       einfo "If you use the map editor then note that maps will be saved as"
-       einfo "~/dh_map.txt and must be move to the correct module directory"
-       einfo "(within ${MODULE_DIR}) by hand."
+       elog "If you use the map editor then note that maps will be saved as"
+       elog "~/dh_map.txt and must be move to the correct module directory"
+       elog "(within ${GAMES_DATADIR}/${PN}) by hand."
        echo
 }