kde-plasma/plasma-desktop: Fix blurry icons in KColorSchemeEditor
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 16 May 2020 19:52:09 +0000 (21:52 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 16 May 2020 22:37:22 +0000 (00:37 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-plasma/plasma-desktop/files/plasma-desktop-5.18.5-KColorSchemeEditor-blurry-icons.patch [new file with mode: 0644]
kde-plasma/plasma-desktop/plasma-desktop-5.18.5-r1.ebuild

diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.18.5-KColorSchemeEditor-blurry-icons.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.18.5-KColorSchemeEditor-blurry-icons.patch
new file mode 100644 (file)
index 0000000..17db7fc
--- /dev/null
@@ -0,0 +1,44 @@
+From 2c46f28170c785f04fa396803037a608c8077025 Mon Sep 17 00:00:00 2001
+From: Matej Mrenica <matejm98mthw@gmail.com>
+Date: Wed, 6 May 2020 07:50:01 -0600
+Subject: Fix blurry icons in KColorSchemeEditor
+
+Summary:
+When using fractional scaling, bottom icons are blurred. This patch fixes the issue.
+
+BUG: 418165
+
+Test Plan:
+No side effects.
+
+Before:
+{F8289358}
+After:
+{F8289369}
+
+Reviewers: #plasma
+
+Subscribers: plasma-devel
+
+Tags: #plasma
+
+Differential Revision: https://phabricator.kde.org/D29481
+---
+ kcms/colors/editor/kcolorschemeeditor.cpp | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/kcms/colors/editor/kcolorschemeeditor.cpp b/kcms/colors/editor/kcolorschemeeditor.cpp
+index 774d66e..03caa51 100644
+--- a/kcms/colors/editor/kcolorschemeeditor.cpp
++++ b/kcms/colors/editor/kcolorschemeeditor.cpp
+@@ -28,6 +28,8 @@
+ int main(int argc, char* argv[])
+ {
++    // Fixes blurry icons with fractional scaling
++    QGuiApplication::setAttribute(Qt::AA_UseHighDpiPixmaps);
+     QApplication app(argc, argv);
+     KAboutData aboutData(
+-- 
+cgit v1.1
index 5b6539dfcd88fe639722b95969a27b60a70f930c..d017862200e11e1aa3c6121ce55f194cec30c112 100644 (file)
@@ -131,6 +131,8 @@ PATCHES=(
        "${FILESDIR}/${P}-findxorgserver.patch" # in Plasma/5.19
        "${FILESDIR}/${P}-override-include-dirs.patch" # downstream patch
 
+       "${FILESDIR}/${P}-KColorSchemeEditor-blurry-icons.patch" # in Plasma/5.18
+
        # Fix animation duration w/ KDE Frameworks 5.70 (Plasma/5.19 backports):
        # https://pointieststick.com/2020/05/10/why-the-animations-in-your-plasma-5-18-feel-slow-now-and-when-it-will-be-fixed/
        "${FILESDIR}/${P}-fix-animate-in-animation.patch"