app-editors/ee: update to EAPI 6
authorAkinori Hattori <hattya@gentoo.org>
Sat, 8 Jul 2017 09:52:07 +0000 (18:52 +0900)
committerAkinori Hattori <hattya@gentoo.org>
Sat, 8 Jul 2017 09:56:34 +0000 (18:56 +0900)
Package-Manager: Portage-2.3.6, Repoman-2.3.1

app-editors/ee/ee-1.5.2.ebuild

index 1af312e8139300a10540a58d048a704ac351962c..250c1e87c8a5d61b930f68801246964bb1a1c2f6 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="4"
+EAPI="6"
 
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
 
 DESCRIPTION="An easy to use text editor. A subset of aee"
 #HOMEPAGE="http://mahon.cwx.net/ http://www.users.uswest.net/~hmahon/"
@@ -18,9 +18,10 @@ IUSE=""
 RDEPEND="!app-editors/ersatz-emacs"
 S="${WORKDIR}/easyedit-${PV}"
 
-src_prepare() {
-       epatch "${FILESDIR}"/${PN}-init-location.patch
+PATCHES=( "${FILESDIR}"/${PN}-init-location.patch )
+DOCS=( Changes README.${PN} ${PN}.i18n.guide ${PN}.msg )
 
+src_prepare() {
        sed -i \
                -e "s/make -/\$(MAKE) -/g" \
                -e "/^buildee/s/$/ localmake/" \
@@ -31,6 +32,8 @@ src_prepare() {
                -e "/CFLAGS =/s/\" >/ \\\\\$(LDFLAGS)\" >/" \
                -e "/other_cflag/s/ *-s//" \
                create.make
+
+       default
 }
 
 src_compile() {
@@ -38,8 +41,8 @@ src_compile() {
 }
 
 src_install() {
-       dobin ee
-       doman ee.1
-       dodoc Changes README.ee ee.i18n.guide ee.msg
+       dobin ${PN}
+       doman ${PN}.1
+       einstalldocs
        keepdir /usr/share/${PN}
 }