media-libs/gexiv2: backport fix for typelibdir
authorMike Gilbert <floppym@gentoo.org>
Tue, 7 Feb 2017 23:41:02 +0000 (18:41 -0500)
committerMike Gilbert <floppym@gentoo.org>
Tue, 7 Feb 2017 23:42:20 +0000 (18:42 -0500)
Bug: https://bugs.gentoo.org/603002
Package-Manager: Portage-2.3.3_p49, Repoman-2.3.1_p42

media-libs/gexiv2/files/0.10.4-typelibdir.patch [new file with mode: 0644]
media-libs/gexiv2/gexiv2-0.10.4-r1.ebuild [moved from media-libs/gexiv2/gexiv2-0.10.4.ebuild with 85% similarity]

diff --git a/media-libs/gexiv2/files/0.10.4-typelibdir.patch b/media-libs/gexiv2/files/0.10.4-typelibdir.patch
new file mode 100644 (file)
index 0000000..7988bd4
--- /dev/null
@@ -0,0 +1,26 @@
+From 7c47e3907c4888190138c3301232e198206217fb Mon Sep 17 00:00:00 2001
+From: Jens Georg <mail@jensge.org>
+Date: Wed, 17 Aug 2016 13:11:18 +0200
+Subject: Fix typelib install directory
+
+Signed-off-by: Jens Georg <mail@jensge.org>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 7b5862f..bfc46d2 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -4,7 +4,7 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+ pkgconfigdir     = $(libdir)/pkgconfig
+ GEXIV2_publicdir = $(includedir)/gexiv2
+ girdir           = $(datadir)/gir-1.0
+-typelibdir       = $(datadir)/gir-1.0
++typelibdir       = $(libdir)/girepository-1.0
+ py2gidir         = $(PYTHON2_GIDIR)
+ py3gidir         = $(PYTHON3_GIDIR)
+ vapidir          = $(datadir)/vala/vapi
+-- 
+cgit v0.12
+
similarity index 85%
rename from media-libs/gexiv2/gexiv2-0.10.4.ebuild
rename to media-libs/gexiv2/gexiv2-0.10.4-r1.ebuild
index e538816b28266303aa601c43ae88fd960b48b99b..c8e2edfa6ec800eadee2f78d0887e2a909921d85 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -6,7 +6,7 @@ EAPI=6
 
 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
 
-inherit eutils multilib python-r1 toolchain-funcs versionator xdg-utils
+inherit autotools eutils multilib python-r1 toolchain-funcs versionator xdg-utils
 
 MY_PV=$(get_version_component_range 1-2)
 
@@ -28,10 +28,15 @@ RDEPEND="${PYTHON_DEPS}
 DEPEND="${RDEPEND}
        virtual/pkgconfig"
 
+PATCHES=(
+       "${FILESDIR}"/0.10.4-typelibdir.patch
+)
+
 src_prepare() {
        xdg_environment_reset
        tc-export CXX
        default
+       eautoreconf
 }
 
 src_configure() {