net-firewall/iptables: Restore 1.4.17 required by dev-perl/IPTables-libiptc
authorMichał Górny <mgorny@gentoo.org>
Fri, 14 Aug 2015 12:41:41 +0000 (14:41 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 14 Aug 2015 12:42:00 +0000 (14:42 +0200)
Package-Manager: portage-2.2.20

net-firewall/iptables/Manifest
net-firewall/iptables/files/iptables-1.4.17-libip6tc.patch [new file with mode: 0644]
net-firewall/iptables/iptables-1.4.17.ebuild [new file with mode: 0644]

index e3c1f23d09e593648b1c167baf6438acde2c1d4d..8e3fa0b3f2d74eca104792520356d8f5fc81901a 100644 (file)
@@ -1 +1,2 @@
+DIST iptables-1.4.17.tar.bz2 541137 SHA256 51e7a769469383b6ad308a6a19cdd2bd813cf4593e21a156a543a1cd70554925 SHA512 022f89cbf56408842bdeb1adbe05076addaad007599fdb662f32a1c134d743dade28c26842acc7545d2474903164be5fe3ec7fd1e276cd2c37bd3b33b8a30de1 WHIRLPOOL f2cb85d5f4080fce2c6673a58737ace3d55130f74c66207bc515d0c7b4ecd75bd7ac8540a862e8af133e740d34eee40833d72c9c3236c7ef4dc75cd43816ec41
 DIST iptables-1.4.21.tar.bz2 547439 SHA256 52004c68021da9a599feed27f65defcfb22128f7da2c0531c0f75de0f479d3e0 SHA512 dd4baccdb080284d8620e6ed59beafc2677813f3e099051764b07f8e394f6d94ca11861b181f3cce7c55c66de64c1e2add13dc1a0b64e24050cd9fb7aea0689b WHIRLPOOL 475541d1b2b7fe4ee8fa3b537274ef082aab8bfd262201ee14cd53577dfac6f591445cc6d64ed93b226a4b71d54ae1b9ab4cbb378b5440861a585f770f0db200
diff --git a/net-firewall/iptables/files/iptables-1.4.17-libip6tc.patch b/net-firewall/iptables/files/iptables-1.4.17-libip6tc.patch
new file mode 100644 (file)
index 0000000..5212dd2
--- /dev/null
@@ -0,0 +1,32 @@
+From d42bc7c100de69396a527e90736198f8e4e3000b Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 30 Dec 2012 18:06:15 -0500
+Subject: [PATCH] extensions: fix linking against -lip6tc
+
+The current build forgets to specify a path to find libip6tc which means
+it either fails (if there is no libip6tc in the system), or links against
+an old version (if there is one in the system).
+
+References: https://bugs.gentoo.org/449262
+Reported-by: Mike Gilbert <floppym@gentoo.org>
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ extensions/GNUmakefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/extensions/GNUmakefile.in b/extensions/GNUmakefile.in
+index e71e3ff..a605474 100644
+--- a/extensions/GNUmakefile.in
++++ b/extensions/GNUmakefile.in
+@@ -101,7 +101,7 @@ libxt_state.so: libxt_conntrack.so
+       ln -fs $< $@
+ # Need the LIBADDs in iptables/Makefile.am too for libxtables_la_LIBADD
+-ip6t_NETMAP_LIBADD  = -lip6tc
++ip6t_NETMAP_LIBADD  = -L../libiptc/.libs -lip6tc
+ xt_RATEEST_LIBADD   = -lm
+ xt_statistic_LIBADD = -lm
+-- 
+1.8.0
+
diff --git a/net-firewall/iptables/iptables-1.4.17.ebuild b/net-firewall/iptables/iptables-1.4.17.ebuild
new file mode 100644 (file)
index 0000000..0bbfa2b
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+# Force users doing their own patches to install their own tools
+AUTOTOOLS_AUTO_DEPEND=no
+
+inherit eutils multilib toolchain-funcs autotools
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 netlink static-libs"
+
+RDEPEND="
+       netlink? ( net-libs/libnfnetlink )
+"
+DEPEND="${RDEPEND}
+       virtual/os-headers
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       # use the saner headers from the kernel
+       rm -f include/linux/{kernel,types}.h
+       epatch "${FILESDIR}"/${P}-libip6tc.patch #449262
+
+       # Only run autotools if user patched something
+       epatch_user && eautoreconf || elibtoolize
+}
+
+src_configure() {
+       # Some libs use $(AR) rather than libtool to build #444282
+       tc-export AR
+
+       sed -i \
+               -e "/nfnetlink=[01]/s:=[01]:=$(usex netlink 1 0):" \
+               configure || die
+
+       econf \
+               --sbindir="${EPREFIX}/sbin" \
+               --libexecdir="${EPREFIX}/$(get_libdir)" \
+               --enable-devel \
+               --enable-shared \
+               $(use_enable static-libs static) \
+               $(use_enable ipv6)
+}
+
+src_compile() {
+       emake V=1
+}
+
+src_install() {
+       default
+       dodoc INCOMPATIBILITIES iptables/iptables.xslt
+
+       # all the iptables binaries are in /sbin, so might as well
+       # put these small files in with them
+       into /
+       dosbin iptables/iptables-apply
+       dosym iptables-apply /sbin/ip6tables-apply
+       doman iptables/iptables-apply.8
+
+       insinto /usr/include
+       doins include/iptables.h $(use ipv6 && echo include/ip6tables.h)
+       insinto /usr/include/iptables
+       doins include/iptables/internal.h
+
+       keepdir /var/lib/iptables
+       newinitd "${FILESDIR}"/${PN}-1.4.13-r1.init iptables
+       newconfd "${FILESDIR}"/${PN}-1.4.13.confd iptables
+       if use ipv6 ; then
+               keepdir /var/lib/ip6tables
+               newinitd "${FILESDIR}"/iptables-1.4.13-r1.init ip6tables
+               newconfd "${FILESDIR}"/ip6tables-1.4.13.confd ip6tables
+       fi
+
+       # Move important libs to /lib
+       gen_usr_ldscript -a ip{4,6}tc iptc xtables
+       find "${ED}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
+}