x11-plugins/pidgin-sipe: Version bump
authorIan Whyman <thev00d00@gentoo.org>
Sat, 15 Jun 2019 13:39:58 +0000 (14:39 +0100)
committerIan Whyman <thev00d00@gentoo.org>
Sat, 15 Jun 2019 13:39:58 +0000 (14:39 +0100)
Closes: https://bugs.gentoo.org/686116
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
x11-plugins/pidgin-sipe/Manifest
x11-plugins/pidgin-sipe/pidgin-sipe-1.24.0.ebuild [new file with mode: 0644]

index f874c39c1590e399c61f8cc44e4fd3dd0aef82bb..ce7c20f82a3ce10fb65c49fba576248fae006ae8 100644 (file)
@@ -1 +1,2 @@
 DIST pidgin-sipe-1.23.3.tar.gz 1298459 BLAKE2B e15ad7658771fc0d7f5320f6b145e67a6f33603dfe49dd83edbf42fd2e57f117f4cdac53c6b6dba401266ae6c2593bb6078a604c164aa365aa94aa64eb94f1c7 SHA512 3c7481e02f9541818a980df31d135c3eefd8f1e921dcb6cfe3d1ce194b1591531db2c23364b545a912eb3818af207ffc0a19d3310d495db503de954f0547ea31
+DIST pidgin-sipe-1.24.0.tar.gz 1322542 BLAKE2B 52ca80e4fb12f24c3406f671d499043f054ea1d4ad6f715d7feafa3df2d2203ccaeb9c0dd8d6214a19b383916d006faf8b284b3c0df9b6fce8926300811898c5 SHA512 9a7906cb6b5514d70b410bac436f6822316b570d1114f684ee96999cf0585816324780428212dd43b0988b22eff615630e9034bb518cb69add890877506b20e3
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.24.0.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.24.0.ebuild
new file mode 100644 (file)
index 0000000..6e1a832
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
+HOMEPAGE="http://sipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="dbus debug kerberos ocs2005-message-hack openssl telepathy voice"
+
+RDEPEND="
+       dev-libs/gmime:2.6
+       dev-libs/libxml2
+       openssl? ( dev-libs/openssl:= )
+       !openssl? ( dev-libs/nss )
+       kerberos? ( virtual/krb5 )
+       voice? (
+               >=dev-libs/glib-2.28.0
+               >=net-libs/libnice-0.1.0
+               media-libs/gstreamer:1.0
+               net-libs/farstream:0.2
+       )
+       !voice? (
+               >=dev-libs/glib-2.12.0:2
+       )
+       net-im/pidgin[dbus?]
+       telepathy? (
+               >=sys-apps/dbus-1.1.0
+               >=dev-libs/dbus-glib-0.61
+               >=dev-libs/glib-2.28:2
+               >=net-libs/telepathy-glib-0.18.0
+       )
+"
+
+DEPEND="dev-util/intltool
+       virtual/pkgconfig
+       ${RDEPEND}
+"
+
+src_configure() {
+       econf \
+               --enable-purple \
+               --disable-quality-check \
+               $(use_enable telepathy) \
+               $(use_enable debug) \
+               $(use_enable ocs2005-message-hack) \
+               $(use_with dbus) \
+               $(use_with kerberos krb5) \
+               $(use_with voice vv) \
+               $(use_enable !openssl nss) \
+               $(use_enable openssl)
+}
+
+src_install() {
+       emake install DESTDIR="${D}"
+       dodoc AUTHORS ChangeLog NEWS TODO README
+}