app-cdr/isomaster: Fix compilation + EAPI 7
authorSebastian Pipping <sping@gentoo.org>
Mon, 27 Jan 2020 22:37:33 +0000 (23:37 +0100)
committerSebastian Pipping <sping@gentoo.org>
Mon, 27 Jan 2020 22:37:50 +0000 (23:37 +0100)
Closes: https://bugs.gentoo.org/706662
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.84, Repoman-2.3.20

app-cdr/isomaster/files/isomaster-1.3.14-include-path.patch [new file with mode: 0644]
app-cdr/isomaster/isomaster-1.3.14.ebuild

diff --git a/app-cdr/isomaster/files/isomaster-1.3.14-include-path.patch b/app-cdr/isomaster/files/isomaster-1.3.14-include-path.patch
new file mode 100644 (file)
index 0000000..520a355
--- /dev/null
@@ -0,0 +1,25 @@
+From 50113aa660d2a867f3f8bfd67e1ba601c8b5294a Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Mon, 27 Jan 2020 23:33:49 +0100
+Subject: [PATCH] Add missing (Gentoo specific) include path for iniparser 4
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 8f4f23b..124a035 100644
+--- a/Makefile
++++ b/Makefile
+@@ -65,7 +65,7 @@ CPPFLAGS +=  -DICONPATH=\"$(ICONPATH)\" -DLOCALEDIR=\"$(LOCALEDIR)\" -DDEFAULT_E
+ CPPFLAGS += -D_FILE_OFFSET_BITS=64
+ ifdef USE_SYSTEM_INIPARSER
+-CPPFLAGS += -DUSE_SYSTEM_INIPARSER=$(USE_SYSTEM_INIPARSER)
++CPPFLAGS += -DUSE_SYSTEM_INIPARSER=$(USE_SYSTEM_INIPARSER) -I/usr/include/iniparser4
+ endif
+ OBJECTS = isomaster.o window.o browser.o fsbrowser.o isobrowser.o error.o about.o settings.o boot.o editfile.o
+-- 
+2.24.1
+
index c30620f0aa1b226b0152fe145569720d5add380c..cbe941cb2b92fc20f641393ecbb82f3b150db83b 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit toolchain-funcs xdg-utils
 
@@ -20,6 +20,10 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig
        nls? ( >=sys-devel/gettext-0.19.1 )"  # bug 512448
 
+PATCHES=(
+       "${FILESDIR}"/${P}-include-path.patch
+)
+
 pkg_setup() {
        myisoconf=(
                DEFAULT_EDITOR=leafpad