media-plugins/kodi-game-libretro-nestopia: 1.50.0.3 versiom bump
authorCraig Andrews <candrews@gentoo.org>
Tue, 2 Jul 2019 21:07:22 +0000 (17:07 -0400)
committerCraig Andrews <candrews@gentoo.org>
Tue, 2 Jul 2019 21:16:29 +0000 (17:16 -0400)
Bug: https://bugs.gentoo.org/688474
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-plugins/kodi-game-libretro-nestopia/Manifest [new file with mode: 0644]
media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-1.50.0.3.ebuild [new file with mode: 0644]
media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-9999.ebuild

diff --git a/media-plugins/kodi-game-libretro-nestopia/Manifest b/media-plugins/kodi-game-libretro-nestopia/Manifest
new file mode 100644 (file)
index 0000000..00cff3d
--- /dev/null
@@ -0,0 +1 @@
+DIST kodi-game-libretro-nestopia-1.50.0.3.tar.gz 793893 BLAKE2B 89015bb8c687685264e4a8c34cf1caad87cfa1a3611cbd67b540ddb31e9e75049eed328b51c69702e92e358a659d4e503ccdac1b52b7db70688e1236529536ad SHA512 4c41db8c77d24301f00b9d0283c948ae3c4176228e733a316fa5b2eba60ceea4dd094f48270d545008f144d3316cf5f8f190017f70e8378b9fbcbcdb2d8220e6
diff --git a/media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-1.50.0.3.ebuild b/media-plugins/kodi-game-libretro-nestopia/kodi-game-libretro-nestopia-1.50.0.3.ebuild
new file mode 100644 (file)
index 0000000..49c4284
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Nestopia GameClient for Kodi"
+HOMEPAGE="https://github.com/kodi-game/game.libretro.nestopia"
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.nestopia.git"
+       inherit git-r3
+else
+       KEYWORDS="~amd64 ~x86"
+       CODENAME="Leia"
+       SRC_URI="https://github.com/kodi-game/game.libretro.nestopia/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/game.libretro.nestopia-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       =media-tv/kodi-18*
+       games-emulation/libretro-nestopia
+       "
+RDEPEND="
+       media-plugins/kodi-game-libretro
+       ${DEPEND}
+       "
+src_prepare() {
+       echo 'find_library(NESTOPIA_LIB NAMES nestopia_libretro${CMAKE_SHARED_LIBRARY_SUFFIX} PATH_SUFFIXES libretro)' > "${S}/Findlibretro-nestopia.cmake" || die
+       default
+}
index 532ff29f02e59b61170099670031758d34b4a781..f57205d8169839bbdf6bf9f863afe866e0849bb5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -15,8 +15,9 @@ if [[ ${PV} == *9999 ]]; then
        inherit git-r3
 else
        KEYWORDS="~amd64 ~x86"
-       SRC_URI="https://github.com/kodi-game/game.libretro.nestopia/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       S="${WORKDIR}/game.libretro.nestopia-${PV}"
+       CODENAME="Leia"
+       SRC_URI="https://github.com/kodi-game/game.libretro.nestopia/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/game.libretro.nestopia-${PV}-${CODENAME}"
 fi
 
 LICENSE="GPL-2"