dev-php/pecl-ps: fix tests
authorThomas Deutschmann <whissi@gentoo.org>
Fri, 29 Nov 2019 13:23:37 +0000 (14:23 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 29 Nov 2019 13:23:37 +0000 (14:23 +0100)
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-php/pecl-ps/pecl-ps-1.4.1.ebuild

index 816c3d9eec8ab4a5886faf7ea8dc57e7ef7be225..fd04378b47c96cde6559aaad62a0a53b93df1149 100644 (file)
@@ -40,3 +40,10 @@ src_install() {
                php-ext-pecl-r3_src_install
        fi
 }
+
+src_test() {
+       if use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
+               # tests/004.phpt depends on set numeric format
+               LC_ALL=C php-ext-pecl-r3_src_test
+       fi
+}