sys-libs/kpmcore: 4.1.0 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 23 Feb 2020 11:29:23 +0000 (12:29 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 23 Feb 2020 11:43:43 +0000 (12:43 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sys-libs/kpmcore/Manifest
sys-libs/kpmcore/kpmcore-4.1.0.ebuild [new file with mode: 0644]

index be88248f7ada24dc57b358c7be64e91af95c0add..753e1d4a1d34d35b47caef1dcc9bacf1727c0abb 100644 (file)
@@ -1 +1,2 @@
 DIST kpmcore-4.0.1.tar.xz 416932 BLAKE2B db429a9a51baf2d3f83d36479c05ac28c1d742dfc9e0dda51486d17958c95751da6295fe9e915359717eebbab3877464284b871dd8ded5a87c01c590cf4eac85 SHA512 982ad77246f59ade74edba15effca6490ac9ac7bb6db7f6194bcdbfddfa735c9bc1b58020affccd945fcdfc96fce3488167f492d6a13dcd6d19c5692505303ac
+DIST kpmcore-4.1.0.tar.xz 420344 BLAKE2B 1a8043c5eb774a3b9b99431543217910120a38b06a17db9db9ae6c577593c2736223e8d466ef62c33224e52513eae52d062584fc8afd86d90eb667af4e923645 SHA512 c45b31a41c62a68aee991be0f7954f4bd2136660578cc60f7fa6f05e56716458421e16cd314b3b9a14b56fdc9377db511c1645e5c41f0446d86a8ac5bb66c273
diff --git a/sys-libs/kpmcore/kpmcore-4.1.0.ebuild b/sys-libs/kpmcore/kpmcore-4.1.0.ebuild
new file mode 100644 (file)
index 0000000..d9ba96a
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_NONGUI="true"
+KFMIN=5.60.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+       SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Library for managing partitions"
+HOMEPAGE="https://kde.org/applications/system/org.kde.partitionmanager"
+
+LICENSE="GPL-3"
+SLOT="5/9"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="
+       || (
+               app-crypt/qca[botan]
+               app-crypt/qca[ssl]
+       )
+       >=dev-qt/qtdbus-${QTMIN}:5
+       >=dev-qt/qtgui-${QTMIN}:5
+       >=dev-qt/qtwidgets-${QTMIN}:5
+       >=kde-frameworks/kauth-${KFMIN}:5
+       >=kde-frameworks/kcoreaddons-${KFMIN}:5
+       >=kde-frameworks/ki18n-${KFMIN}:5
+       >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+       >=sys-apps/util-linux-2.33.2
+"
+RDEPEND="${DEPEND}"
+
+# bug 689468, tests need polkit etc.
+RESTRICT+=" test"