sys-auth/google-authenticator: 1.09 version bump
authorCraig Andrews <candrews@gentoo.org>
Tue, 26 May 2020 14:19:07 +0000 (10:19 -0400)
committerCraig Andrews <candrews@gentoo.org>
Tue, 26 May 2020 14:20:16 +0000 (10:20 -0400)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Craig Andrews <candrews@gentoo.org>
sys-auth/google-authenticator/Manifest
sys-auth/google-authenticator/google-authenticator-1.09.ebuild [new file with mode: 0644]

index af61280777273ff3af879c54bd7c9fc7fd21656a..dc3e70fca857d2c509905d48396d24bc76e6160a 100644 (file)
@@ -1 +1,2 @@
 DIST google-authenticator-1.08.tar.gz 62767 BLAKE2B ae1f5b1feac40da9beec28c81f39edfcc5e46df4cad4575d76deda9a183e8324ded79af9b7831c0572682749bb209b5371747b98a114af404d3225b9b0ff15f8 SHA512 f53d2fc20b5fa0f4621566509a2ef746077e3345de289bd2c9565440eb972e3a80807bf50a2cce8e2cc520df72c2e236629a921e3fce90fd635aff0c0ef36f75
+DIST google-authenticator-1.09.tar.gz 62944 BLAKE2B 85ddb0a9eec3d49eba1f9e84ca1375783fd21d19bd969ab9ca4324fd956628aea7bb937a2441bdb300ab0e157891962c9d9c979de17cc542df425f3528f00d95 SHA512 c71cec3200214f7a6c7f7f33fdc0f00e812b378940be92017785bbba82236b90d443977a2af12465285316e3dade0313f4d6df1f3d85f37f830d9877c7c33754
diff --git a/sys-auth/google-authenticator/google-authenticator-1.09.ebuild b/sys-auth/google-authenticator/google-authenticator-1.09.ebuild
new file mode 100644 (file)
index 0000000..27600a5
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+if [[ ${PV} == 9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/google/google-authenticator-libpam.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/google/google-authenticator-libpam/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+       S="${WORKDIR}/google-authenticator-libpam-${PV}"
+fi
+
+DESCRIPTION="PAM Module for two step verification via mobile platform"
+HOMEPAGE="https://github.com/google/google-authenticator-libpam"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/1.08-remove-failing-tests.patch" )
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       # We might want to use getpam_mod_dir from pam eclass,
+       # but the build already appends "/security" for us.
+       econf --libdir="/$(get_libdir)"
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       if [[ -z ${REPLACING_VERSIONS} ]] ; then
+               elog "For further information see"
+               elog "https://wiki.gentoo.org/wiki/Google_Authenticator"
+               elog ""
+               elog "If you want support for QR-Codes, install media-gfx/qrencode."
+       fi
+}