net-firewall/iptables-1.8.4-r1: revbump, add eselect (bug 698746)
authorPatrick McLean <patrick.mclean@sony.com>
Fri, 20 Mar 2020 00:09:37 +0000 (17:09 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Fri, 20 Mar 2020 00:09:53 +0000 (17:09 -0700)
This makes the ebuild compatible with eselect-iptables.

Closes: https://bugs.gentoo.org/698746
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
net-firewall/iptables/files/iptables-1.8.4-no-symlinks.patch [new file with mode: 0644]
net-firewall/iptables/iptables-1.8.4-r1.ebuild [new file with mode: 0644]

diff --git a/net-firewall/iptables/files/iptables-1.8.4-no-symlinks.patch b/net-firewall/iptables/files/iptables-1.8.4-no-symlinks.patch
new file mode 100644 (file)
index 0000000..349a01a
--- /dev/null
@@ -0,0 +1,19 @@
+diff --git a/iptables/Makefile.am b/iptables/Makefile.am
+index 71b1b1d4..30c77f9a 100644
+--- a/iptables/Makefile.am
++++ b/iptables/Makefile.am
+@@ -71,12 +71,10 @@ CLEANFILES       = iptables.8 xtables-monitor.8 \
+ vx_bin_links   = iptables-xml
+ if ENABLE_IPV4
+-v4_sbin_links  = iptables-legacy iptables-legacy-restore iptables-legacy-save \
+-               iptables iptables-restore iptables-save
++v4_sbin_links  = iptables-legacy iptables-legacy-restore iptables-legacy-save
+ endif
+ if ENABLE_IPV6
+-v6_sbin_links  = ip6tables-legacy ip6tables-legacy-restore ip6tables-legacy-save \
+-               ip6tables ip6tables-restore ip6tables-save
++v6_sbin_links  = ip6tables-legacy ip6tables-legacy-restore ip6tables-legacy-save
+ endif
+ if ENABLE_NFTABLES
+ x_sbin_links  = iptables-nft iptables-nft-restore iptables-nft-save \
diff --git a/net-firewall/iptables/iptables-1.8.4-r1.ebuild b/net-firewall/iptables/iptables-1.8.4-r1.ebuild
new file mode 100644 (file)
index 0000000..5fd4425
--- /dev/null
@@ -0,0 +1,153 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Force users doing their own patches to install their own tools
+AUTOTOOLS_AUTO_DEPEND=no
+
+inherit multilib systemd toolchain-funcs autotools flag-o-matic usr-ldscript
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="https://www.netfilter.org/projects/iptables/"
+SRC_URI="https://www.netfilter.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+# Subslot reflects PV when libxtables and/or libip*tc was changed
+# the last time.
+SLOT="0/1.8.3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE="conntrack ipv6 netlink nftables pcap static-libs"
+
+COMMON_DEPEND="
+       app-eselect/eselect-iptables
+       conntrack? ( >=net-libs/libnetfilter_conntrack-1.0.6 )
+       netlink? ( net-libs/libnfnetlink )
+       nftables? (
+               >=net-libs/libmnl-1.0:0=
+               >=net-libs/libnftnl-1.1.5:0=
+       )
+       pcap? ( net-libs/libpcap )
+"
+DEPEND="${COMMON_DEPEND}
+       virtual/os-headers
+       >=sys-kernel/linux-headers-4.4:0
+"
+BDEPEND="
+       virtual/pkgconfig
+       nftables? (
+               sys-devel/flex
+               virtual/yacc
+       )
+"
+RDEPEND="${COMMON_DEPEND}
+       nftables? ( net-misc/ethertypes )
+"
+
+PATCHES=(
+       "${FILESDIR}/iptables-1.8.4-no-symlinks.patch"
+       "${FILESDIR}/iptables-1.8.2-link.patch"
+)
+
+src_prepare() {
+       # use the saner headers from the kernel
+       rm include/linux/{kernel,types}.h || die
+
+       default
+       eautoreconf
+}
+
+src_configure() {
+       # Some libs use $(AR) rather than libtool to build #444282
+       tc-export AR
+
+       # Hack around struct mismatches between userland & kernel for some ABIs. #472388
+       use amd64 && [[ ${ABI} == "x32" ]] && append-flags -fpack-struct
+
+       sed -i \
+               -e "/nfnetlink=[01]/s:=[01]:=$(usex netlink 1 0):" \
+               -e "/nfconntrack=[01]/s:=[01]:=$(usex conntrack 1 0):" \
+               configure || die
+
+       local myeconfargs=(
+               --sbindir="${EPREFIX}/sbin"
+               --libexecdir="${EPREFIX}/$(get_libdir)"
+               --enable-devel
+               --enable-shared
+               $(use_enable nftables)
+               $(use_enable pcap bpf-compiler)
+               $(use_enable pcap nfsynproxy)
+               $(use_enable static-libs static)
+               $(use_enable ipv6)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       emake V=1
+}
+
+src_install() {
+       default
+       dodoc INCOMPATIBILITIES iptables/iptables.xslt
+
+       # all the iptables binaries are in /sbin, so might as well
+       # put these small files in with them
+       into /
+       dosbin iptables/iptables-apply
+       dosym iptables-apply /sbin/ip6tables-apply
+       doman iptables/iptables-apply.8
+
+       insinto /usr/include
+       doins include/iptables.h $(use ipv6 && echo include/ip6tables.h)
+       insinto /usr/include/iptables
+       doins include/iptables/internal.h
+
+       keepdir /var/lib/iptables
+       newinitd "${FILESDIR}"/${PN}-r2.init iptables
+       newconfd "${FILESDIR}"/${PN}-r1.confd iptables
+       if use ipv6 ; then
+               keepdir /var/lib/ip6tables
+               dosym iptables /etc/init.d/ip6tables
+               newconfd "${FILESDIR}"/ip6tables-r1.confd ip6tables
+       fi
+
+       if use nftables; then
+               # Bug 647458
+               rm "${ED}"/etc/ethertypes || die
+
+               # Bug 660886
+               rm "${ED}"/sbin/{arptables,ebtables} || die
+
+               # Bug 669894
+               rm "${ED}"/sbin/ebtables-{save,restore} || die
+       fi
+
+       systemd_dounit "${FILESDIR}"/systemd/iptables-{re,}store.service
+       if use ipv6 ; then
+               systemd_dounit "${FILESDIR}"/systemd/ip6tables-{re,}store.service
+       fi
+
+       # Move important libs to /lib #332175
+       gen_usr_ldscript -a ip{4,6}tc xtables
+
+       find "${ED}" -type f -name "*.la" -delete || die
+}
+
+pkg_postinst() {
+       local default_iptables="xtables-legacy-multi"
+       if ! eselect iptables show &>/dev/null; then
+               elog "Current iptables implementation is unset, setting to ${default_iptables}"
+               eselect iptables set "${default_iptables}"
+               use ipv6 && eselect iptables set --ipv6 "${default_iptables}"
+       fi
+       eselect iptables show
+}
+
+pkg_prerm() {
+       elog "Unsetting iptables symlinks before removal"
+       eselect iptables unset
+
+       # the eselect module failing should not be fatal
+       return 0
+}